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Galaxy Invaders - A1) Setup

Load up Clickteam Fusion 2.5

From the top menu select File' > 'New Application’

You are now in the ‘Storyboard Editor

[Reusable Skill - Save your game]

From the top menu select ‘File' > 'Save’ (name your file if it's unnamed)

[End Skill]

Select the application from the top of the Workspace Toolbar to load its Properties
From the Properties window select the 'Window' category

Click and type in the 'Size' "640" x "640" and press Enter

When prompted about changing the frame sizes also, click Yes'

Click on the number 1" on the first frame preview or the
Frame Editor logo to enter the "FRAME EDITOR"

With ‘Frame 1’ selected in the ‘Workspace Toolbar’ click on the ‘Settings’
(white paper with red tick) category

Click on the white box next to ‘Background color’ and select a background color,
we will choose black.



Galaxy Invaders - A2) Player

[Reusable Skill - Insert an Object]

From the Top Bar click ‘Insert’ > 'New Object’

Click on Active (Available from "All Objects or ‘Graphics and Animation category)
Click 'OK’

Click at the bottom the Play Area to place your object

[End SkKill]

[Reusable Skill - Rename]

With the active object selected (blue box around it) from the 'Properties window' select the
‘About’ category

Click on the current name and type in "P 1"

Press Enter to accept the new name

[End Skill]

[Reusable Skill - Movement Property]

In the 'Properties Window' ‘Movement’' Category in Type' select > 'Eight Directions’ *
(not Physics 8 directions)

[End SkKill]

Set the 'Directions’: click the black square to only have arrows
on the left and right squares (numbers 16 , 0)

Right-Click on the “P 1” and click 'Edit’ to open the ‘Image Editor’
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Galaxy Invaders - A2) Player

In the 'Image Editor’

Draw a player spaceship facing upwards
OR

[Reusable Skill - Import Animation]
Click 'Import’

Select your first image file from the
animation “player_1.png"

Check ‘'Import as Animation’
Set Hotspot: center
Set Action point: center

Click OK to close the import window
Click on “Direction Options”
Set the animation speed: 30,

and check Loop

Click OK to save changes to the Image Editor
[End]

05



Galaxy Invaders - A3) Bullets

[Insert an Object] Insert an active object
and place off screen

ﬁ [Rename] “good bullet”

Right-Click on the “bullet” and click 'Edit’ to
open the ‘Image Editor’

Draw a laser facing upwards

OR

[Import Animation] “good bullet_1.png”,
Direction options> animation speed: 30,
Loop:checked

w

[Insert an Object] Insert an active
object and place off screen

[Rename] “enemy bullet”

Right-Click on the “enemy bullet” and click 'Edit’ to open the ‘Image Editor’Draw a laser
facing to the right

OR

[Import Animation] “enemy bullet_1.png”, Direction options> animation speed: 30,
Loop:checked
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Galaxy Invaders - A3) Bullets

ﬁ [Reusable Skill - Create animation directions]

Still in the Image Editor/Edit view, pull the blue slider under the directions view to the right
to increase the number of available direction animations to 32 (the maximum).

Right-click on the black box that the direction arrow is pointing to
and click on Create rotated directions’

[End Skill]

Click ‘OK’ to exit
the ‘image editor’
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Galaxy Invaders - A4) Move & Shoot

Click on the EVENT EDITOR icon just under to top menu to load the 'Event Editor

Click on the last number next to 'New Condition’ to select the last line. From the Top Menu
click ‘Insert’ > 'Group of Events' > set the Title of the group’’ to "Player controls” click 'OK’

In the new group click on the words New Condition > P 1" > 'Position’ > Test position of P 1™
> Click on the left arrow and right arrows on the edge the white Frame area pointing from the
white to the grey > 'OK

On that row right-click to add an action under 'P 1" > ‘Movement' > 'Stop’

Click on the words ‘New Condition' > 'The mouse pointer and keyboard' > ‘The keyboard' >
'Repeat while key is pressed’ > press space bar.

On that row right-click to add an action under 'P 1" > ‘Launch an object’ > 'bullet’ > Speed of
object: 80, check 'Launch in a selected direction’ select 8 (up) 'OK' > 'OK’

[Save your game]

~ " [Reusable skill - Test your game]

From the Top Menu click ‘Run’ > 'Frame’ (Or ‘Application’, as there is only one frame)
Try the arrows to move the ship, hold spacebar to fire.
If the window is still open after you have tested your code, close it,

otherwise it will restrict your work in the Editors
[End Skill]
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Galaxy Invaders - A4) Move & Shoot

IBUG! Our player is totally overpowered, we need to slow the rate of fire

Still in the ‘Event Editor’ right-click on the words from the last condition ‘Repeat while
“Space bar” is pressed’ > ‘Insert’ > ‘good bullet’ > ‘Pick or count’ > ‘Compare to the number
of “good bullet” objects’ > Leave the settings as ‘equals’ ‘0’ > ‘OK’

[Test your game] Try the arrows to move the ship, hold the spacebar to fire.

IBUG! No bullets, this is because there is already one bullet in the game outside the play area
Click on “good bullet” in the Workspace Toolbar

In the ‘Properties Window’ in the ‘Runtime options’ category uncheck Create at start

[Test your game]

[Save your game]
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Galaxy Invaders - B1) Enemy Formation

Click on the FRAME EDITOR icon just under to top menu to load the ‘Frame Editor
Click on ‘Grid Setup’ (9 dots and red arrows) from the

‘Editor toolbar’ under the ‘Top menu’

Set

X: 0

y: 0

width: 32

height: 32

snap to: check

Click ‘OK’

[Insert an Object] Add and ‘Active’ object and place it at the top centre of the screen
[Rename] “enemy position”

Right-Click on the “enemy position” and click 'Edit’ to open the ‘Image Editor’
Click the ‘Clear’ button (white paper, ctrl+N) in the top left of ‘Image editor’

Choose a color from the palette, we will use a blue

Select the ‘Fill’ tool (paint bucket, F) and click on the sprite/blank image to make a blue
square.

Click ‘OK’ to save your changes
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Galaxy Invaders - B1) Enemy Formation

[Reusable skill - Set Initial Value]
In the 'Properties Window' select the Values' category (A-Z logo)

Under ‘Alterable Values’ click ‘New’

Right-click on the words “Alterable Value A” >
‘Rename’ > “id” > ‘OK’
[End Skill]

These blue blocks will be the enemies’ positions so drag from the ‘Asset bar’ as many enemies
as you want. Put them in a formation.

[Movement Property] ‘Invaders’ movement at the (bottom of the list)
Set

Move at Start: checked

Step Size in X: 10

Step SizeinY: 32

Speed: 50

317 [Save your game]

[Test your game] Check the “enemy position” boxes move as you want.
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Galaxy Invaders - B2) Adding Enemies

[Insert an Object] Insert an active object and place off screen
[Rename] “enemy 1”
Right-Click on the “enemy” and click Edit’ to open the ‘Image Editor’

Draw an enemy facing to the right
OR
[Import Animation] “enemy_1_1.png” Direction options> animation speed: 30, Loop:checked

[Create animation directions]
Click ‘OK’ to exit the ‘image editor’

[Set Initial Value] “Alterable Value A” = “id” : 0
[Set Initial Value] “Alterable Value B” = “points” : 10
[Set Initial Value] “Alterable Value C” = “shoot” : 0

Add 2 new flags and rename them
[Set Initial Value] “Flag 0” = “drop” unchecked
[Set Initial Value] “Flag 1” = “return” unchecked

[New SKill - Add to a Qualifier group]

In the 'Properties Window' select the 'Events’ category

Click in the blank space next to Qualifiers row > 'Edit’ > 'Add’
Select 'Enemies’ (Lightning)' click 'OK' to close the add window
Click 'OK' to close the Qualifiers window.

[End Skill]
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Galaxy Invaders - B2) Adding Enemies

[Insert an Object] ‘Counter’ place off screen
[Rename] “id count”

[Insert an Object] ‘Score’ place off screen,
as it will be black and our background is black

Right-click on the score and click ‘Edit’

Select a color for your score you want
from the color palette (so it stands out from black),
we’ll choose red.

Click the ‘Text Tool’ button (A letter A, or press T) =
‘Import Font’ > Choose a font, style and size
- ioK! = !OK!

Drag the score to the top right corner of the screen
Select ‘'enemy 1' and in the 'Properties Window'
select the ‘Movement’ category set the initial

direction to be just up (8)

Drag from the ‘Asset Bar’ an ‘'enemy 1’ for each ‘enemy position’
and place them on top of the blue position boxes



Galaxy Invaders - B2) Adding Enemies

Click on the EVENT EDITOR icon to load the 'Event Editor

Click on the last number next to 'New Condition’ to select the last line. From the Top Menu
click ‘Insert’ > 'Group of Events' > set the Title of the group’ to “enemy movement” click 'OK’

In the new group click on the words 'New Condition’ > 'Storyboard Controls’ > 'Start of Frame’

On that row right-click to add an action under ‘'enemy position’ > ‘Count’ > 'For each object’ >
name to loop “set id” (include double quotation marks) > ‘OK’

In the ‘enemy movement’ group click on the words 'New Condition’ > ‘'enemy position’ >
‘Loops’ > 'For each object’ > “set id” (include double quotation marks) > ‘OK’

Right-click on the words ‘On each one of’ and click ‘Insert’
‘enemy position’ > ‘Collision’ > ‘Overlapping another object’ > ‘Group.Enemies’ (Lightning)

On that condition’s row right-click under the ‘id count’ counter > ‘Add to counter’ > 1 > ‘OK’
On the same row right click under the ‘enemy position’ > ‘Alterable Values’ > ‘Set’ > ‘id’ and
in the bottom box click on the ‘id count’ counter and select ‘current value’ (expression should

automatically fill in value(“id count”) ) then click ‘OK’

Do the same action for ‘Group.Enemies’ > ‘Alterable Values’ > ‘Set’ >
‘id’ value(“id count”) > ‘OK’

14



Galaxy Invaders - B2) Adding Enemies

This will mean when the game starts all the enemy positions will be given a number as an ‘id’
and the enemies on top will have a matching ‘id’ number.

This next part is slightly complex and is a condition made of 4 parts, but will make sure the
enemies only move with the correct positions at the correct times.

In the ‘enemy movement’ group click on the words 'New Condition’ > ‘Special’ > 'Always’

On that condition’s row right-click under the ‘Group.Enemies’ (Lightning) > ‘Count’ > ‘For
each object’ > name it “move” and click ‘OK’

Right-click on the words ‘On each one of’ and click ‘Insert’
‘enemy position’ > ‘Alterable Values’ >

‘Compare to one of the alterable values’ >

‘id’ ‘equal to’ click on the Group.Enemies > ‘Values’ >
‘Values A to M’ > ‘id’ this should write out

id( "Group.Enemies” )

click ‘OK’

Right-click on the words ‘Id of’ > ‘Insert’ > ‘Group.Enemies’ > ‘Alterable Values’ > ‘Flags’ >
‘Is a flag off?’ > ‘drop’ > ‘OK’

Right-click on the words ‘drop is off’ > ‘Insert’ > ‘Group.Enemies’ > ‘Alterable Values’ >
‘Flags’ > ‘Is a flag off?’ > ‘return’ > ‘OK’

That’s all the rules added to the condition
On that row right-click to add an action under ‘Group.Enemies’ > 'Position’ >
‘Select Position’ > check ‘Relative to’ > ‘enemy position’ > ‘OK’ > ‘OK’

[Test your game] Check the enemies move with the positions [Save your game]
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Galaxy Invaders - B3) Shooting Enemies

Still in the 'Event Editor

Click on the last number next to 'New Condition’ to select the last line. From the Top Menu
click ‘Insert’ > ‘Group of Events' > set the Title of the group’ to "Combat” click 'OK’

In the new group click on the words 'New Condition’ > 'good bullet’ > 'Collisions’ > 'Another
object’ > ‘Group.Enemies’

On that condition’s row right-click under the ‘Player 1’ > ‘Score’ > ‘Add to score’ > click on
the Group.Enemies (Lightning) icon > ‘Alterable Values’ > ‘Values A to M’ > ’Retrieve points’

On that condition’s row right-click under the ‘Group.Enemies’ (Lightning) > ‘Destroy’

On the same row right-click under the ‘good bullet’ > ‘Destroy’
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Galaxy Invaders - B4) Enemy attack

In the new group click on the words 'New Condition > The Timer > 'Every > 1/100th : 1 > ‘OK’

On that condition’s row right-click under the ‘Group.Enemies’ (Lightning) > ‘Alterable Values’
> ‘Set’ > change ‘id’ to ‘shoot’ click the Random button and type in 800, so the text reads
Random(800)

click ‘OK’

In the group click on the words ‘New Condition' > ‘Group.Enemies’ (Lightning) > ‘Alterable
Values’ > ‘Compare to one of the alterable values’ > change ‘id’ to ‘shoot’ ‘equal to’ 1 > ‘OK’

Right-click on the words ‘Id of’ > ‘Insert’ > ‘Group.Enemies’ > ‘Alterable Values’ > ‘Flags’ > ‘Is
a flag off?’ > ‘drop’ > ‘OK’

On that row right-click to add an action under ‘Group.Enemies’ > ‘Launch an object’ > ‘enemy
bullet’ > ‘OK’ > Speed of object: 50, check ‘Launch in selected directions..’ > uncheck up (8)
check (24) so only down is selected > ‘OK’ > ‘OK’

In the group click on the words 'New Condition’ > ‘enemy bullet’ > ‘Collision’ > ‘Another
object’ > ‘P 1’

On that condition’s row right-click under the ‘Player 1’ (Joystick) > ‘Lives’ > ‘Subtract from
lives’ > 1 > ‘OK’

On the same row right-click under the ‘enemy bullet’ > ‘Destroy’
[Test your game] Check the enemies fire at you
IBUG! You cannot die and lives aren’t shown
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Galaxy Invaders - B4) Enemy attack
In the ‘combat’ group click on the words 'New Condition’ > ‘Player 1’ > ‘When number of lives
reaches zero’
On that row right-click under ‘P 1’ and click Destroy, later in section D we will add highscores
Click on the Frame Editor logo to enter the "FRAME EDITOR"
[Insert an Object] ‘Lives’ place bottom left
Right-click on the lives click ‘Edit’

Draw a spaceship or ‘Import’ “lives.png”

[Save your game]



Galaxy Invaders - C1) Drop zone

We will be getting the enemies to break formation to attack you.
We will set them to have another movement type.

Select ‘enemy 1’

[Movement Property] Click on Movement #0 > ‘+ / -’ button > ‘Create new movement’
(Black boundary box with yellow shine) > ‘OK’

Set

Movement: Movement #1 (Make sure you’re not editing ‘Movement #0’)

Type: Bouncing Ball

Initial Direction: 7,9

Speed: 30

We need to define an area the enemies can shoot at you while attacking as they can’t be too
close to you when shooting.

[Insert an Object] Insert an ‘Active’ object,
[Rename] “drop zone”

Right-Click on the ‘drop zone’ and click 'Edit’ to open the ‘Image Editor’

Click the ‘Clear’ button (white paper, ctrl+N) in the top left of ‘Image editor’
Choose a color from the palette, we will use a pink

Select the ‘Fill’ tool (paint bucket, F) and click on the sprite/blank image
to make a pink square.
Click ‘OK’ to save your changes

19



Galaxy Invaders - C1) Drop zone

Once the ‘drop zone’ is selected click on it one more time to show the resize squares on the
side and corners.

Move and resize the ‘drop zone’ to cover from below the enemies to leaving a gap above the
player

We don’t need this ‘drop zone’ object or the ‘enemy position’ object visible so for each, click
on them to select them (the Asset bar might be easiest place to select them)

In the ‘Properties Window’ under the ‘Display Options’ (Blue screen with white arrows)
category uncheck ‘Visible at start’

Do this for both the ‘drop zone’ object and the ‘enemy position’ object

20



Galaxy Invaders - C2) Dive bomb

Click on the EVENT EDITOR icon to load the 'Event Editor

In the ‘enemy movement’ group click on the words 'New Condition' > ‘The Timer’ > ‘Every’ >
‘Use a calculation’ > click on ‘Random Range’ and make the expression look like this
RRandom(2000, 5000)

Then click ‘OK’

Right-click on the words ‘Every RRandom(2000,5000)’ and click ‘Insert’ > ‘Group.Enemies’ >
‘Alterable Values’ > ‘Flags’ > ‘Is a flag off?’ > ‘drop’ > ‘OK’

Right-click on the words ‘drop is off’ and click ‘Insert’ > ‘Group.Enemies’ > ‘Pick or count’ >
‘Pick “Group.Enemies” at random’

Add 3 actions under the ‘Group.Enemies’ for that condition:

Right-click > ‘Movement’ > ‘Multiple movements’ > ‘Select movement’ > 1 > ‘OK’
Right-click > ‘Flags’ > ‘Set on’ > ‘drop’ > ‘OK’

Right-click > ‘Direction’ > ‘Select direction’ > 7 & 9 > ‘OK’

ﬁ [Save your game]

’ ~ [Test your game]
IBUG! The enemies fly upwards and disappear

We will need to add a rule to get the enemies to curve in to attack the player.
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Galaxy Invaders - C3) Wiggly dive

Still in the ‘Event Editor’

In the ‘enemy movement’ group click on the words 'New Condition’ > ‘The Timer’ > ‘Every’ >
1/100th : 10 > ‘OK’

Right-click on the words ‘Every’ > ‘Insert’ > ‘Group.Enemies’ > ‘Alterable Values’ > ‘Flags’ > ‘Is
a flag on?’ > ‘drop’ > ‘OK’

Right-click on the words ‘Is drop on’ > ‘Insert’ > ‘Group.Enemies’ > ‘Direction’ > ‘Compare
direction of “Group.Enemies”’ > select numbers 0-7 and 25-31 (all arrow on the right side
right) > ‘OK’

Add an action by right-clicking underneath ‘Group.Enemies’ for that row

‘Direction’ > ‘Select direction’ > ‘1+1’ (Use a calculation) >

Click on the ‘Group.Enemies’ icon > ‘Animation’ > ‘Current direction value’ then type -1 so the
expression is:

Dir(“Group.Enemies”)-1

> ‘OK’
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Galaxy Invaders - C3) Wiggly dive

Repeat for the left side condition and counterclockwise rotation action

In the ‘enemy movement’ group click on the words 'New Condition' > ‘The Timer’ > ‘Every’ >
1/100th : 10 > ‘OK’

Right-click on the words ‘Every’ > ‘Insert’ > ‘Group.Enemies’ > ‘Alterable Values’ > ‘Flags’ > ‘Is
a flag on?’ > ‘drop’ > ‘OK’

Right-click on the words ‘Is drop on’ > ‘Insert’ > ‘Group.Enemies’ > ‘Direction’ > ‘Compare
direction of “Group.Enemies”’ > select numbers 8-23 (all arrow on the left side right and up) >
GOKF

Add an action by right-clicking underneath ‘Group.Enemies’ for that row

‘Direction’ > ‘Select direction’ > ‘1+1’ (Use a calculation) >

Click on the ‘Group.Enemies’ icon > ‘Animation’ > ‘Current direction value’ then type + 1 so
the expression is:

Dir(“Group.Enemies”)+1

> ‘0K’
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Galaxy Invaders - C3) Wiggly dive

Now we’ll make the enemies aim at ‘P 1’

In the ‘enemy movement’ group click on the words 'New Condition’ > ‘Group.Enemies’ >
‘Alterable Values’ > ‘Flags’ > ‘Is a flag on?’ > ‘drop’ > ‘OK’

Right-click on the words ‘Is drop on’ > ‘Insert’ > ‘Group.Enemies’ > ‘Group.Enemies’ >
‘Direction’ > ‘Compare direction of “Group.Enemies”’ > select number 24 (down) > ‘OK’

Add an action by right-clicking underneath ‘Group.Enemies’ for that row
‘Direction’ > ‘Look in direction of’ > ‘Relative to’ > ‘P 1’ > ‘OK’ > ‘OK’

[Test your game]
IBUG! Enemies don’t return or attack you when diving

[Save your game]
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Galaxy Invaders - C4) Attack & Return

Still in the ‘Event Editor’
Starting with returning the enemies to their formation

In the ‘enemy movement’ group click on the words 'New Condition’ > ‘Group.Enemies’ >
‘Position’ > ‘Compare Y position to a value’ > ‘greater than’ click on the Storyboard icon
(Chess board) and click ‘Frame’ > ‘Height’ and add a +20 so it reads

Frame Height + 20

> ‘OK’

Add 3 actions under the ‘Group.Enemies’ for that condition:

Right-click > ‘Flags’ > ‘Set off’ > ‘drop’ > ‘OK’

Right-click > ‘Flags’ > ‘Set on’ > ‘return’ > ‘OK’

Right-click > ‘Position’ > ‘Set Y Coordinate...” > -20 (Note the minus) > ‘OK’

That will replace them at the top of the screen, home to get them to home in on their
previous position.

In the ‘enemy movement’ group click on the words ‘New Condition’ > ‘Group.Enemies’ >
‘Alterable Values’ > ‘Flags’ > ‘Is a flag on?’ > ‘return’ > ‘OK’

Right-click on the words ‘return is on’ and click ‘Insert’

‘enemy position’ > ‘Alterable Values’ > ‘Compare to one of the alterable values’ > ‘id’ ‘equal
to’ click on the Group.Enemies > ‘Values’ > ‘Values A to M’ > “id’ this should write out

id( "Group.Enemies” )

click ‘OK’

Add an action by right-clicking underneath ‘Group.Enemies’ for that row
‘Direction’ > ‘Look in direction of’ > ‘Relative to’ > ‘enemy position’ > ‘OK’ > ‘OK’ 25



Galaxy Invaders - C4) Attack & Return

Now a 3 condition rule to get them to rejoin formation when they arrive back

In the ‘enemy movement’ group click on the words 'New Condition’ > ‘Group.Enemies’ >
'Collisions’ > 'Another object’ > ‘enemy position’

Right-click on the words ‘Collision between’ and click ‘Insert’ > ‘Group.Enemies’ > ‘Alterable
Values’ > ‘Flags’ > ‘Is a flag on?’ > ‘return’ > ‘OK’

Right-click on the words ‘return is on’ and click ‘Insert’

‘enemy position’ > ‘Alterable Values’ > ‘Compare to one of the alterable values’ > ‘id’ ‘equal
to’ click on the Group.Enemies > ‘Values’ > ‘Values A to M’ > ‘id’ this should write out

id( "Group.Enemies” )

click ‘OK’

Now a 4 action response under ‘Group Enemies’

Right-click > ‘Movement’ > ‘Multiple movements’ > ‘Select movement’ > 0 > ‘OK’

Right-click > 'Position’ > 'Select Position’ > check ‘Relative to’ > ‘enemy position’ > ‘OK’ > ‘OK’
Right-click > ‘Flags’ > ‘Set off’ > ‘return’ > ‘OK’

Right-click > ‘Direction’ > ‘Select direction’ > 8 > ‘OK’

w

ﬁ [Save your game]
[Test your game]

{

" 1BUG! Enemies still don’t attack you when diving down, or hurt you when 2 6
they hit into your spaceship P 1’



Galaxy Invaders - C4) Attack & Return

Still in the ‘Event Editor’
Now we’ll add attacking, first for a collision

In the ‘Combat’ group click on the words 'New Condition’ > ‘Group.Enemies’ > ‘Collision’ >
‘Another object’ > ‘P 1’

On that condition’s row right-click under the ‘Player 1’ (Joystick) > ‘Lives’ > ‘Set number of
lives’ > 0 > ‘OK’

Now we get dropping enemies more likely to fire
In the ‘combat’ group click on the words 'New Condition" > ‘Group.Enemies’ (Lightning) >
‘Alterable Values’ > ‘Compare to one of the alterable values’ > change ‘id’ to ‘shoot’ ‘Lower’

T "0R

Right-click on the words ‘shoot of” and click ‘Insert’ > ‘Group.Enemies’ > ‘Alterable Values’ >
‘Flags’ > ‘Is a flag on?’ > ‘drop’ > ‘OK’

Right-click on the words ‘drop is on’ and click ‘Insert’
‘Group.Enemies’ > ‘Collision’ > ‘Overlapping another object’ > ‘drop zone’

On that row right-click to add an action under ‘Group.Enemies’ > ‘Launch an object’ >

‘enemy bullet’ > ‘OK’ > Speed of object: 50, check ‘Launch in direction of’ >
check ‘Relative to’ > ‘P 1’ > ‘OK’ > ‘OK’

[Save your game] 2 7
[Test your game]
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Galaxy Invaders - D1) Sounds & Stars

You can insert animations for ‘P 1’ and ‘enemy 1’ for when they are destroyed
When editing the images select the ‘Disappearing’ animation and draw an animation or import
“player destroyed_1.png” / “enemy destroyed_1.png”

In the ‘Direction Options’ of the animation, set the ‘Speed’: 25

Sounds can be added to the conditions when

Start of Frame = Play and loop sample > “Chronos music.mp3”> 0 for infinite loop
Player fires = Play sample > “player fires.wav”

Player is hit = Play sample > “player hit.mp3”

Player is destroyed = Play sample > “player destroyed.mp3”

Enemy fires = Play sample > “enemy fires.mp3”
Enemy dives = Play sample > “dive.mp3”
Enemy is destroyed = Play sample > “enemy destroyed.mp3”

To add the stars first go to the Frame Editor
[Insert an Object] ‘Active’ place it to the side of the play area

ﬁDraw a small star OR [Import artwork] “star.png”

[Rename] “star”

[Movement Property] Type:'Bouncing ball’
‘Initial direction’: 24

‘Speed’: 10
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Galaxy Invaders - D1) Sounds & Stars

Click on the EVENT EDITOR icon to load the 'Event Editor

Click on the last number next to 'New Condition’ to select the last line. From the Top Menu
click ‘Insert’ > ‘Group of Events’ > set the Title of the group’ to “stars” click 'OK'

In the new group click on the words 'New Condition > ‘Storyboard Controls’ > ‘Start of Frame’

Right-click under ‘Special’ (cogs) on that row > ‘Fast loops’ > ‘Start loop’ > “stars” ‘OK’ > 100
GOKF

In the new group click on the words 'New Condition’ > 'Special’ > 'On loop’ > “stars” ‘OK’

Right-click under ‘Create new objects’ (shiny box) on that row > ‘Create object’ > select ‘star’
and click ‘OK’ > Click the to move the target off the play area > ‘OK’
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Galaxy Invaders - D1) Sounds & Stars

Add 3 action to the ‘star’ object that was just created

Right-click > ‘Position’ > ‘Set X Coordinate...” > Random(Frame Width) > ‘OK’
Right-click > ‘Position’ > ‘Set Y Coordinate...’ > Random(Frame Height) > ‘OK’
Right-click > ‘Order’ > ‘Send to back’

In the new group click on the words New Condition > 'star’ > 'Position’ > ‘Test position of
“stars” object’ > Click the arrow in the white box that points down > ‘OK’

Right-click under ‘star’ object on that row > ‘Movement’ > ‘Wrap Around Play Area’

In the new group click on the words 'New Condition" > 'The Timer' > 'Every' > 1/100th : 20 >
SOKF

Right-click under ‘star’ object on that row > ‘Effect’ > ‘Set alpha-blending coefficient’ >
RRandom(100, 200) ‘OK’

[Save your game]

[Test your game] Check the stars travel down the screen
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Galaxy Invaders - D2) Title Screen

While in the Event Editor
Right-click on the stars group and click ‘copy’

Click on the STORYBOARD EDITOR icon just under to top menu to load the ‘Storyboard Editor’
Click the grey number 2 to add a new Frame (You can title this frame “title screen”)

Drag the blank Thumbnail for frame 2 onto the thumbnail for frame 1 to charge the frame
order

Click the number ‘1’ next to the blank thumbnail

With ‘Frame 1’ selected in the ‘Workspace Toolbar’ click on the ‘Settings’ (white paper with
red tick) category

Click on the white box next to ‘Background color’ and select a background color, we will
choose black.

[Insert and object] Add Strings and Active objects to decorate and name your game

In the ‘Workspace Toolbar’ expand Frame 2 (Press the + button) and drag and drop the stars
object into this frame
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Galaxy Invaders - D2) Title Screen

Click on the EVENT EDITOR icon to load the ‘Event Editor

Right click on the ‘1’ next to New Condition and click ‘Paste’ to add the stars code to this
Frame

Click on the words ‘New Condition’ > The mouse pointer and keyboard' > 'The keyboard > 'Upon
pressing a key' > press space bar.

Right-click on that row under ‘Storyboard Controls’ (Chess board) > Next Frame
[Test your game] Run the application

[Save your game] Next we’ll add an end screen
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Galaxy Invaders - D3) End Screen & Highscores

While in the Event Editor
Right-click on the stars group and click ‘copy’

Click on the STORYBOARD EDITOR icon just under to top menu to load the ‘Storyboard Editor’
Click the grey number 3 to add a new Frame (You can title this frame “end score”)

Click the number ‘3’ next to the blank thumbnail

With ‘Frame 3’ selected in the ‘Workspace Toolbar’ click on the ‘Settings’ (white paper with
red tick) category

Click on the white box next to ‘Background color’ and select a background color, we will
choose black.

[Insert and object] Add Strings and Active objects to decorate and insert a ‘Highscore object’.

In the ‘Workspace Toolbar’ expand Frame 2 (Press the + button) and drag and drop the stars
object into this frame
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Galaxy Invaders - D3) End Screen & Highscores

Click on the EVENT EDITOR icon to load the ‘Event Editor

Right click on the ‘1’ next to New Condition and click ‘Paste’ to add the stars code to this
Frame

Click on the words ‘New Condition' > 'The mouse pointer and keyboard' > "'The keyboard' > ‘Upon
pressing a key' > press space bar.

Right-click on that row under ‘Storyboard Controls’ (Chess board) > Restart Application
[Test your game] Run the application

IBUG! The game doesn’t take you to the end screen

Click on the STORYBOARD EDITOR icon just under to top menu to load the 'Storyboard Editor’

Click the number ‘2’ next to the game thumbnail
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Galaxy Invaders - D3) End Screen & Highscores

Click on the EVENT EDITOR icon to load the 'Event Editor
Now we’ll add the code to end the game for when you win.

In the ‘combat’ group click on the words 'New Condition’ > ‘Group.Enemies’ > ‘Pick or count’ >
‘Have all “Group.Enemies” been destroyed’

Right-click under ‘The Timer’ on that row > ‘Fire an event after given delay’ > ‘second’: 1
{I‘.Endﬂ GOK!

Also in the ‘combat’ group find Number of lives of “Player 1” reaches 0
Right-click under ‘The Timer’ on that row > ‘Fire an event after given delay’ > ‘second’: 3
ilEnd!? IOK!

Under ‘Group.Enemies’ on that row we’ll add 3 actions

Right-click > ‘Movement’ > ‘Multiple movements’ > ‘Select movement’ > 1 > ‘OK’
Right-click > ‘Flags’ > ‘Set on’ > ‘drop’ > ‘OK’

Right-click > ‘Direction’ > ‘Select direction’ > 7 & 9 > ‘OK’

In the ‘combat’ group click on the words 'New Condition' > ‘The Timer’ > ‘On event’ > “end”
GOK!

Right-click on that row under ‘Storyboard Controls’ (Chess board) > Next Frame

[Save your game]

[Test your game] 3 5
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Galaxy Invaders - D4) More Enemies

In the Frame Editor for Frame 2

[Reusable Skill - Clone an Object]

Right click on the ‘enemy 1" object > 'Clone Object’ > leave the settings as Rows: 2 Columns: 1
click 'OK

Clickteam has now created a copy below called “enemy 2’
[End]

You can either delete some ‘enemy 1’ objects and add ‘enemy 2’ in their place,
OR insert some more ‘enemy position’ objects for them to follow.

You can edit their artwork OR import “enemy 2_1.png”

You can change their speed
in their ‘Movement properties’

You can change their points
in their ‘Value Properties’

[Save your game]

[Test your game]
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