HORROR BA11
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HORROR BA11 - A1) Ball and Physics

Load up Clickteam Fusion 2.5

From the top menu select ‘File' > 'New Application’

You are now in the 'Storyboard Editor’

[Reusable Skill - Save your game]

From the top menu select ‘File' > 'Save’ (name your file if it's unnamed)

[End Skill]

Select the application from the top of the Workspace Toolbar to load its Properties
From the 'Properties window' select the 'Window' category

Click and type in the 'Size' "1280" x "720" and press Enter

When prompted about changing the frame sizes also, click ‘Yes'

Click on the number ‘1" on the first frame preview or the
~ Frame Editor logo to enter the "FRAME EDITOR"

[Reusable Skill - Insert an Object]

From the Top Bar click Insert’ > 'New Object’

Click on Active (Available from ‘'All Objects’ or ‘Graphics and Animation’ category)
Click 'OK’

Click in the Play Area to place your object

[End Skill]



HORROR BA11 - A1) Ball and Physics

W [Reusable Skill - Import Artwork]

Right-Click on the Object and click ‘Edit’ to open the ‘Image Editor’
Click on the import button (folder icon, Ctrl+0)
Find and select the image ‘ball.png” and click 'OK’ to load image

Make sure:
‘Hot Spot’ is set to “Centre of mass”

and click 'OK’ to import

Click 'OK' to close the ‘Image Editor’

. [End Skill]

[Reusable Skill - Select a Movement]
With the object selected from the ‘Properties Window' select the
‘Movement' category (Blue running person)

Click on "Static” next to Type' and select "Physics - Static Movement”
[End Skill]

When prompted about adding a Physics-Engine click 'OK’
In the ‘Properties Window' set

Elasticity:20
uncheck Auto Rotations
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HORROR BA11 - A1) Ball and Physics

~ [Reusable Skill - Rename]
With the object selected from the 'Properties window' select the ‘About’ category (Yellow
speech bubble)

Click on the current name and type in "Pinball”

Press Enter to accept the new name
[End Skill]

[Insert an Object] 'Physics Engine’, and place to the right hand side off screen
With the 'Physics Engine’ object selected in the ‘Properties Window' select the ‘About’ category

(White paper with red tick)
Set

. Gravity: 30

[Reusable skill - Test your game]
From the Top Menu click 'Run’ > 'Frame’ (Or 'Application’, as there is only one frame)

If the window is still open after you have tested your code, close it,
otherwise it will restrict your work in the Editors
[End Skill]

The 'Pinball’ object should fall off screen
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HORROR BA11 - A2) Wall Obstacles

[Insert an Object] Backdrop (Available from "All Objects’ or ‘Background’ category)

[Reusable Skill - Change backdrop type]
In the ‘Properties Window' select the 'Runtime options' category

Click on type and select the option "Obstacle”
[End Skill]

[Reusable Skill - Import Artwork] "barrier shapes_1.png"

[Reusable Skill - Clone an Object]

Right click on the ‘Backdrop’ object > 'Clone Object’ > leave the settings as Rows: 2 Columns: 1
click 'OK’

Clickteam has now created a copy below called ‘Backdrop 2’

[End]

[Import Artwork] "barrier shapes_2.png" and you can repeat this process or

ITip! You can drag and drop a selection of images all at once from a folder into the Frame
Editor  in Clickteam Fusion (best to do this in the grey side of the 'Play area’)

When you do you chose their type as ‘Backdrop’ and
check the box ‘Assign this type to further imported items (skip this dialog)

Add in all the "barrier shapes” into the Frame as ‘Backdrops’ select them all
and [Change backdrop type] to ‘Obstacle’
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HORROR BA11 - A2) Wall Obstacles

Drag some of '‘Backdrop's objects under the 'Pinball

[Test your game]

IBug! The 'Pinball’ will fall through all the ‘Backdrop’s, we need to add an event to fix this
Click on the EVENT EDITOR icon to load the 'Event Editor

Click on the words ‘New Condition’ to bring up a window of objects, select the 'Pinball’ object
‘Collisions’ > '‘Backdrop’

On that row under the ‘Pinball’ object right-click for an action.
‘Movemnt' > 'Stop’

[Test your game] The 'Pinball’ should now not pass through the ‘Backdrop’s as they are
‘Obstacles’
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HORROR BA11 - A3) Playfield Layout

Click on the FRAME EDITOR icon to load the 'Frame Editor

Select 'Frame 1’ from the 'Workspace Toolbar

In the ‘Properties Window' select the 'Settings' category
Click on the numbers to the right of 'Size’

Change to 1280 x "3000" (to expand the height)

Press Enter or click away to save the new setting

[Insert an Object] '‘Quick Backdrop’

In the Properties Window' select the ‘Settings' category

Change the Fill Type' to "Motif"

Click on the import button (folder icon, Ctrl+0)

Find and select the image ‘pinball bg.png’ and click 'Open’ to load image

Click 'OK'’ to close the image importer.
Click 'OK' to close the image editor.

In the Properties Window' select the 'Size/Position’ category (In the 'Properties Window' select
the ‘Display Options’ category (Square with arrows logo)

Set X:0 Y:0 Width:1280 Height:3000

From the Top Menu’ click ‘Arrange’ and 'Lock’ to stop it from being moved o 8
or selected accidently



HORROR BA11 - A3) Playfield Layout

Drag in and position the '‘Backdrop' objects to build your Pinball playfield.
There is an example (saved as "template.mfa” on the wesbite)

Try to leave a gap at the top to allow for score later.
Include a side lane (Shooter lane) for the plunger lane.

Where the flipper will go we will add an new object.
[Insert and object] ‘Active’

[Import Artwork] “flipper cover 1.png”

[Rename] “flipper cover 1"

[Change Movement Type] "Physics - Background”

In the ‘Property Window' in the ‘Settings’ category set
Object Obstacle: "Obstacle”

This object needs to be Active so it can go on top of the flippers later
[Clone an object] Rows:2 Columns:1 ‘Flipper Cover 1" to make number 2

Right-click on 'Flipper Cover 2’ click 'Edit’
Click the 'Flip Horizontally' button (two rectangles and arrows poining left right)

Click the 'Hotspot’ (Eye) button then the ‘G’ to set the centre to the
centre of mass, click 'OK'
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HORROR BA11 - A3) Playfield Layout

[Test your game]

~ 1Bug! The screen doesn't follow the 'Pinball’
Click on the EVENT EDITOR icon to load the 'Event Editor’
Click on the words 'new 'New Condition’ > ‘Special’ (Cogs) > 'Always’

On that row right-click under 'Storyboard controls’ > 'Scrollings’ > ‘Centre window position in
frame' > 'Relative to' > 'Pinball’ > 'OK' > "OK’

[Test your game]

Click on the words 'new 'New Condition’ > 'Pinball’ > 'Position’ > ‘Test position of "Pinball™
> Click on 3 arrows on the edge the white Frame area pointing from the white to the grey
(Left Top & Right) > 'OK’

B On that row right-click to add an action under 'Pinball’ > ‘Movement’ > 'Stop’

[Reusable Skill - Save your game]
From the top menu select ‘File' > 'Save’ (name your file if it's unnamed)
[End Skill]
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HORROR BA11 - A4) Tilt

Still in the EVENT EDITOR

Click on the last number next to 'New Condition’ to select the last line. From the Top Menu’
click ‘Insert’ > 'Group of Events' > set the Title of the group” to "Tilt" click 'OK’

In the Tilt" group click 'New Condition’ > 'The mouse pointer and keyboard > The keyboard' >
‘Upon pressing a key'

Press the up arrow on the keyboard

On that row right-click to add an action under ‘Pinball’ > ‘Movement’ > 'Physics’ > ‘Apply impulse’
> 100 (force) > 'OK" > 90 (angle) > 'OK

Repeat add conditions for

s Press Down arrow: impulse 100 angle 270

Press Left arrow: impulse 100 angle 90
Press Right arrow: impulse 100 angle 0

[Test your game] Try unsing the arrow keys to move the ball
In the Optional section we can add a tilt alarm.

[Save your game]
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HORROR BA11 - B1) Plunger

Click on the FRAME EDITOR icon to load the 'Frame Editor’
[Insert an Object] ‘Active’ at the bottom of the screen
[Import Artwork] ‘spring1.png’

Make sure:

‘Import As Animation’ is unchecked

‘Hot Spot’ is set to “Centre of mass”

[Rename] ‘plunger

Position the plunger at the bottom right of the screen in the shooter lane.

[Insert an Object] ‘Counter’ place off screen

& [Rename] ‘pull back’

In the 'Properties Window' select the ‘Settings' category set
Inital value:0

Minimum value: 0

Maximim value:100

In the 'Properties Window' select the 'Size/Position’ category

Make a note of the Y position of the ‘plunger’, in our example it's "2944"
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HORROR BA11 - B1) Plunger

Click on the EVENT EDITOR icon to load the 'Event Editor

Click on the last number next to ‘New Condition’ to select the last line. From the Top Menu’
click ‘Insert’ > 'Group of Events' > set the Title of the group” to "plunger” click 'OK’

Click on the words 'new 'New Condition’ > 'Special’ (Cogs) > ‘Always’

On that row right click under the 'Plunger’ object,
'Position’ > 'Set Y Coordinate’ > 2944+value("pull back”) > 'OK’

Click on the words 'new 'New Condition’ > 'The mouse pointer and keyboard" > The keyboard' >
‘Repeat while key is pressed’ > push the spacebar

On that row right click under the ‘pull back’ counter
'Add to counter’ > 1 > 'OK

Again...
Click on the words 'new ‘New Condition' > 'The mouse pointer and keyboard' > The keyboard' >
‘Repeat while key is pressed’ > push the spacebar

This time right-click on the words "Repeat While" and click ‘Negate’
We'll add a limit to this condition right-click on the words "Repeat While" and click ‘Insert’

'Special’ (Cogs) > Limit’ > 'Only on action when event loops’

On that row right click under ‘'the timer > ‘Fire an event after a given delay’ > , 3
Set all values to 0 > 'OK" > "fire” (include double quotation marks) > 'OK’



HORROR BA11 - B1) Plunger

Click on the words 'new ‘New Condition’ > 'the timer' (Stopwatch) > 'On Event’ > "fire” (include
double quotation marks) > 'OK’

Right-click the word "On time event” and choose ‘Pinball’ > 'Collision’ > 'Overlapping another
object’ > ‘Plunger

On that row right-click to add an action under 'Pinball’ > ‘'Movement' > 'Physics’ > ‘Apply impulse’

> 10*value("pull back”) (force) > 'OK' > 90 (angle) > 'OK

Again

Click on the words 'new ‘New Condition’ > 'the timer' (Stopwatch) > 'On Event’ > "fire” (include
double quotation marks) > 'OK’

On that row right-click to add an action under 'pull back’ > 'Set counter’ > 0 > 'OK'

Click on the FRAME EDITOR icon to load the 'Frame Editor’

Move the 'Pinball’ down the frame to above the 'Plunger’

[Test your game] Hold space and let go

IBug! The Pinball’ falls through the Plunger’

Click on the ‘Plunger
[Select a Movement] 'Physics - Background’, Obstacle:"Obstacle”, uncheck ‘Auto Rotations’

[Test your game] Hold space and let go to fire the 'Pinball’ [Save your game]
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HORROR BA11 - B2) Flippers

1 [Insert an Object] 'Active’
7 [Import Artwork] ‘Flipper’, Hotspot: Centre of Mass

A" [Rename] ‘flipper left

Position it half over 'Flipper cover 1’
Right Click on ‘flipper left’ > ‘Order’ > To Back'

[Select a Movement] 'Physics - Background', Obstacle:"Obstacle”, uncheck ‘Auto Rotations’

In the ‘Properties Window' in the 'Values' category click for a 'New' value
Double click on the name ‘Alterable Value A’ and name it “rest angle”

£ Set rest angle’ value to 340

[Clone an Object] ‘flipper left’

[Rename] ‘flipper right’

Position it half over ‘Flipper cover 2’

Right Click on ‘flipper left’ > ‘Order’ > To Back’

In the 'Properties Window' in the 'Values' category
Set ‘rest angle’ value to 280

[Insert an Object] ‘Counter’ place to side of screen
[Rename] 'LEFT SIDE'

[Clone an Object] 'LEFT SIDE'

[Rename] RIGHT SIDE'
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HORROR BA11 - B2) Flippers

Click on the EVENT EDITOR icon to load the 'Event Editor

Click on the last number next to 'New Condition’ to select the last line. From the Top Menu’ click ‘Insert’
> 'Group of Events' > set the Title of the group” to "flippers” click 'OK’

Click on the words new 'New Condition’ > 'The mouse pointer and keyboard' > The keyboard' > 'Upon
pressing a key' > Press "Z"

Click on the words 'new '‘New Condition’ > 'the timer' (Stopwatch) > ‘'Fire an event a number times after
a given delay’ > Set all values 0 > 60 > 'OK’" > 'Use Calculation’ > 1 > 'OK’ > "left up” (Keep quotation
marks) 'OK'

Click on the words 'new ‘New Condition' > 'the timer' (Stopwatch) > 'On event' > "left up” 'OK’

On that row right-click to add an action under 'LEFT SIDE’ counter > ‘Add to counter' > 1 'OK"

On that row right-click to add an action under ‘flipper left’ > 'Scale/Angle’ >
rest angle("flipper left") + value("LEFT SIDE") > 'OK' > 0 > 'OK’

Click on the words 'new '‘New Condition’ > 'The mouse pointer and keyboard > The keyboard' > 'Repeat
while key is pressed’' > Press "z

Right click on "Repeat while" > ‘Negate'

On that row right-click to add an action under 'LEFT SIDE' counter > 'Set counter > 0 'OK '

On that row right-click to add an action under ‘flipper left' > 'Scale/Angle’ > , 6
rest angle("flipper left”) > 'OK > 0 > 'OK’



HORROR BA11 - B2) Flippers

Now for the right hand side flippers (be careful to select the right flipper and counter)

Click on the words 'new 'New Condition’ > 'The mouse pointer and keyboard' > The keyboard' > 'Upon
pressing a key' > Press "/"

Click on the words 'new 'New Condition' > 'the timer' (Stopwatch) > ‘Fire an event a number times after
a given delay’ > Set all values 0 > 60 > 'OK’ > 'Use Calculation' > 1 > 'OK" > "right up” (Keep quotation
marks) 'OK'

Click on the words new 'New Condition’ > 'the timer' (Stopwatch) > 'On event’ > "right up® 'OK'

On that row right-click to add an action under RIGHT SIDE" counter > ‘'Add to counter > 1 'OK"

On that row right-click to add an action under ‘flipper right> 'Scale/Angle’ >
rest angle("flipper right") + value("RIGHT SIDE") > 'OK" > 0 > 'OK’

Click on the words 'new ‘New Condition > The mouse pointer and keyboard > The keyboard' > 'Repeat
while key is pressed’ > Press "/"

Right click on "Repeat while" > 'Negate'

On that row right-click to add an action under 'RIGHT SIDE" counter > 'Set counter’ > 0 'OK

On that row right-click to add an action under ‘flipper right' > 'Scale/Angle’ >
rest angle("flipper right”)> 'OK > 0 > 'OK’
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HORROR BA11 - B2) Flippers

Now to check for collisions during the flipper moving

Click on the words 'new ‘New Condition' > 'the timer' (Stopwatch) > 'On event' > "left up” 'OK’
Right-click on the 'On timer event' > ‘Insert’

flipper left’ > 'Collisions’ > 'Overlapping another object’ > 'Pinball’ > 'OK’

On that row right-click under Pinball’ > ‘Movement' > 'Physics’ > ‘Apply impulse’ >
100-value("LEFT SIDE") > 'OK" > Angle("flipper left") + 90 > 'OK’

Click on the words new 'New Condition’ > 'the timer' (Stopwatch) > 'On event’ > "right up® 'OK'
Right-click on the 'On timer event’ > ‘Insert’
flipper right’ > ‘Collisions’ > ‘Overlapping another object’ > ‘Pinball’ > 'OK’

On that row right-click under 'Pinball’ > ‘Movement' > 'Physics’ > "Apply impulse’ >
100-value("RIGHT SIDE") > 'OK’ > Angle("flipper right”) - 90 > 'OK’

Click on the FRAME EDITOR icon to load the 'Frame Editor’
[Test your game]

If your flippers move out from behind their covers reposition them and test again

[Save your game] , 8



HORROR BA11 - B3) Slingshots

W [Insert an Object] ‘Backdrop
@ [Import Artwork] 'Slingshot.png’ Hotspot: Centre of Mass

[Rename] ‘slingshot 1'
In the 'Properties Window' set it's 'Runtime Options’' to have Obstacle Type:"Obstacle”

" [Clone] 'Slingshot 1.png' rows:2, columns: 1
[Rename] ‘slingshot 2’

[Insert an Object] 'Active’
_[Import Artwork] ‘Slingshot rubber.png’ Hotspot: Centre of mass
[Rename] 'ss rubber 1'

Drag the 'ss rubber 1’ to just overlap the side of ‘slingshot 1'

[Movement Property] "Physics - Static Movement”, Elasticity:200, uncheck Auto Rotations

In the ‘Properties Window' in the Values' category click for a 'New' value
Double click on the name "Alterable Value A" and name it "points”
Set ‘points’ value to any value (we used 11)

In the ‘Properties Window' in the ‘Events’ category click next to ‘Qualifier(s)’
Click ‘Edit’ > ‘New' > ‘Bonus’ & ‘Explosions’ > 'OK" > 'OK’

By [Clone] ‘'ss rubber 1" rows:2, columns:1

4 [Rename] 'ss rubber 2’
Right-click on it and choose 'Edit’, set the Hotspot’ (eye icon) to 'G’
Position it over ‘slingshot 2'
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HORROR BA11 - B4) Drain and Lives

~ [Save your game]

® . [Insert an Object] Lives

[Import Artwork] 'ball.png’
Resize and position it to next to the shooter lane

Click on the EVENT EDITOR icon to load the 'Event Editor

Click on the last number next to ‘New Condition’ to select the last line. From the Top Menu' click ‘Insert’ >
'Group of Events' > set the Title of the group” to "balls” click 'OK’

Click on the words 'new ‘New Condition’ > 'Pinball’ > ‘Position’ > ‘Compare Y position to a value' > Change
dropdown to ‘Greater than' in the expression box below type in

Frame Height + 30

> '0K’

On the row right-click under ‘Pinball’ > 'Destroy’

Right-click on that row under the 'Player 1’ (joystick) object > 'Subtract from number of lives' > 1 > 'OK’

Right-click on that row under ‘the timer object > 'Fire an event after a given delay’ > 3 seconds > "new ball"
> 0K’

Click on the words 'new 'New Condition’ > 'The mouse pointer and keyboard' >
‘The keyboard’ > ‘Upon pressing a key' > press spacebar

Right-click on that row under 'the timer object > ‘Fire an event after a given delay’ > 2 o
0 seconds > "new ball” > 'OK’



HORROR BA11 - B4) Drain and Lives

To limit new balls being created every time spacebar is pressed we will add some limits

Click on the words 'new 'New Condition’ > 'the timer' (Stopwatch) > 'On event’ > "new ball" 'OK’
Right-click on the 'On timer event’ > ‘Insert’

'Pinball’ > 'Pick or count’ > 'Compare to the number of "Pinball” objects’ > "Equals” 0 > 'OK’
Right-click on the 'Number of > ‘Insert’

‘Player 1" > 'Compare to the number of lives' > "Greater” 0 > 'OK’

On the row right-click under ‘Create new object’ > 'Pinball’ > 'OK’' > Click/Drag the target to above the
plunger > 'OK’

Click on the words 'new 'New Condition’ > 'The mouse pointer and keyboard' >
‘The keyboard' > ‘Upon pressing a key' > press spacebar

Right-click on the 'Upon pressing’ > ‘Insert’

Player 1" > ‘Compare to the number of lives' > "Equals” 0 > 'OK’

On the row right-click under 'Storyboard controls’ > ‘Restart application’

Click on the FRAME EDITOR icon to load the 'Frame Editor’

Position the 'Pinball’ between the flippers

{ [Test your game] !Bug! Lives are shown off screen

To fix click on the ‘Lives' and in the 'Properties Window' 'Runtime Options’

tick/check Follow the frame 2 ,

Now right-click on the original 'Pinball’ and 'Delete’ it from your frame



HORROR BA11 - C1) Score display

[Save your game]
Open the 'Layers Toolbar’ by clicking on the Layers Toolbar tab on the right hand side of the frame.

ITip! If the Layer Toolbar is not available reactivate it from the top menu
'View' > Toobars' > ‘Layer' (or press Control+K)

Click the white piece of paper to create a new layer.
Select Layer 2, in its 'Property’ 'Settings’ set Y coefficient’ : O

[Insert an Object] '‘Backdrop’
In the Property Windows' in the ‘Settings' change the ‘Color' to black

Click on the Backdrop once it's selected and the resize corner squares should appear
Drag and reposition it to fill a top section of the screen

[Insert an Object] ‘Score’

In the Property Windows' in the 'Settings' change the Type: "Text"

In the ‘Property Windows' in the Text Options’ change the Color and Font to stand out from the black
screen.

»_ Resize and position it on the top bar

8 [Insert an Object] 'String
" In the 'Property Windows' in the Text Options' change the Color and Font

to stand out from the black screen.
[Rename] “Info” 2 2

[Save your game]



HORROR BA11 - C2) Bumpers

Open the 'Layers Toolbar’ by clicking on the Layers Toolbar tab on the right hand side of the frame.
Select Layer 1 (Important, layer 2 is just for the heads up display)

[Insert an Object] 'Active’

. [Import Artwork] ‘jet bumper 1.png’ tick/check Import as animation’

[Rename] 'big jet bumper

[Movement Property] "Physics - Background”
Obstacle Type: Obstacle

Elasticity : 150

Collision shape: “Circle”

In the ‘Properties Window' in the 'Values' category click for a 'New' value
Double click on the name ‘Alterable Value A" and name it "points”
Set ‘points’ value to any value (we used 101)

In the ‘Properties Window' in the ‘Events’ category click next to ‘Qualifier(s)’
Click ‘Edit’ > 'New' > 'Bonus’ & ‘Explosions’ > 'OK’ > 'OK’

Duplicate extra versions of the bumper, or clone and resize them.
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HORROR BA11 - C2) Bumpers

Click on the EVENT EDITOR icon to load the 'Event Editor’

Click on the last number next to 'New Condition’ to select the last line. From the Top Menu' click ‘Insert’ >
'Group of Events' > set the Title of the group” to "Points” click 'OK’

Click on the words "New Condition’ > Pinball’ > 'Collisions’ > 'Overlapping another object’ >

'Group.Explosions’
On that row right-click to add an action under 'Player 1’ > '‘Add to score’ >

points("Group.Explosions”)
On that row right-click to add an action under ‘Group.Explosions’ > ‘Flags' > 'Set on’ > 'Flag 0" > 'OK’

Again click on the words 'new 'New Condition’ > 'Pinball’ > ‘Collisions’ > ‘Overlapping another object’ >
‘Group.Explosions’
Right-cick on "Is overlapping” > ‘Negate'

On that row right-click to add an action under ‘Group.Explosions’ > ‘Flags' > ‘Set off' > 'Flag 0" > 'OK’

Click on the words ‘New Condition’ > ‘Group.Bonus’ > 'Alterable values' > 'Flags' > 'Is flag on?' >
'Flag 0" > 'OK’

On that row right-click to add an action under ‘Group.Bonus' > ‘Animation’ >

‘Change animation frame' > 1 > 'OK’

Click on the words'New Condition’ > ‘Group.Bonus' > 'Alterable values > Flags > 'Is flag off?' >
'Flag 0" > 'OK’

On that row right-click to add an action under ‘Group.Bonus’ > ‘Animation’ >
‘Change animation frame' > 0 > 'OK’ 2q



HORROR BA11 - C3) Roll-over Targets

Click on the FRAME EDITOR icon to load the 'Event Editor

& [Insert an Object] ‘Active'
 [Import Artwork] ‘light yellow 1.png’ tick/check 'Import as animation’
W) [Rename] "top roll over”

In the ‘Properties Window' in the 'Values' category click for a 'New' value
Double click on the name ‘Alterable Value A" and name it "points”
Set ‘points’ value to any value (we used 1100)

In the 'Properties Window' in the 'Events’ category click next to '‘Qualifier(s)’
Click 'Edit’ > 'New' > ‘Bonus’ & ‘Glow' > 'OK" > 'OK’

Click on the EVENT EDITOR icon to load the 'Event Editor
Click on the words 'New Condition’ > 'Pinball’ > ‘Collisions’ > ‘Another object’ > 'Group.Glow'

On that row right-click to add an action under 'Player 1’ > 'Add to score’ >
points("Group.Glow")

- ®._ On that row right-click to add an action under ‘Group.Glow' > ‘Flags' > 'Set on" > 'Flag 0" > 'OK’

[Test your game] !Bug! The lights stay lit even with a new ball

To fix, on the row for the condition 'On timer event "new ball™ right-click to add an
action under ‘Group.Bonus’ > 'Flags' > 'Set off' > 'Flag 0" > 'OK' 2 5



HORROR BA11 - C4) Drop Targets

Click on the FRAME EDITOR icon to load the 'Event Editor

& " [Insert an Object] ‘Active
__ [Import Artwork] ‘drop target 1.png’ tick/check ‘Import as animation’
[Rename] "drop down 1"

In the ‘Properties Window' in the 'Values' category click for a 'New' value
Double click on the name ‘Alterable Value A" and name it "points”
Set ‘points’ value to any value (we used 11011)

In the 'Properties Window' in the 'Events’ category click next to '‘Qualifier(s)’
Click 'Edit’ > 'New' > ‘Bonus’ & ‘Shields’ > 'OK" > 'OK’

Click on the EVENT EDITOR icon to load the 'Event Editor’

Click on the words ‘New Condition’ > 'Pinball’ > ‘Collisions’ > ‘Another object’ > ‘Group.Sheild’
Right-click on the words “collides with" > ‘Insert’

'Group.Sheild’ > 'Flags' > 'Is flag off? > 'Flag 0" > 'OK’

On that row right-click to add an action under 'Player 1" > 'Add to score’ >
points("Group.Shields"”)

On that row right-click to add an action under ‘Group.Sheilds’ > ‘Flags' > ‘Set on’ > 'Flag 0’ > 'OK’
[Test your game]

Duplicate, clone, rotate to add more variations of drop targets on your playfield 2 6

[Save your game]



HORROR BA11 - D1) Named Points

For all Bonus group objects, you can add a name

In the 'Properties Window' in the 'Values' category Strings 'New'
Then set the string to the name you want the points

Click on the EVENT EDITOR icon to load the 'Event Editor

We will filter the events to only show those to do with score or lives.
Click on the ‘Player 1’ (joystick) icon on the heading row to filter the events

For the 3 events shown the ‘points’ group add the following action.

Right-click under the ‘Info’ string object > ‘Change alterable string’ >

Alterable string A("Group.Bonus")+NewLineS$+Str$(points("Group.Bonus”))

[Test your game] Your points whould now display on the top HUD
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HORROR BA11 - D2) Bonus Banks

Click on the FRAME EDITOR icon to load the 'Frame Editor’

For all roll-over or drop down targets, you can group them into a bank for a combo score
In the ‘Properties Window' in the 'Values' category add 2 new values

‘BANK id' : Choose a ungiue number per group

'bonus’ : Choose the points you'll get for getting all targets in a bank

[Insert an Object] ‘Counter

[Rename] ‘Bank Check’

Click on the EVENT EDITOR icon to load the 'Event Editor

From the Top Menu’ click ‘Insert’ > ‘Group of Events' > set the Title of the group” to "banks” click 'OK’

Click on the words 'New Condition’ > Pinball’ > 'Collisions’ > 'Another object’ > ‘Group.Bonus’
Right-click under ‘Bank Check’ > 'Set counter’ > BANK id("Group.Bonus")

ITip! If not all values are labels it will be named 'Alterable Value B' not 'BANK id’
Right-click under 'the timer' > 'Fire an event after a delay’ > 0 seconds > "check” > 'OK’
Click on the words ‘New Condition’ > 'the timer' > 'On Event’ > "check” > 'OK’

Right-click under ‘Group.Bonus' > '‘Count’ > 'For each object’ > "bonus” > 'OK’ 2 8



HORROR BA11 - D2) Bonus Banks

Click on the words ‘New Condition’ > ‘Group.Bonus’ > 'Loop’ > "bonus” > 'OK’

Right-click on the condition words "On each” > ‘Insert’

'Group.Bonus' > 'Alterable Values' > 'Compare to one of the Alterable Values' >
'BANK id' or 'Alterabel Value B' > "Equals”

value("bank check”) > 'OK’

Right-click on the condition words "On each” > ‘Insert’
'Group.Bonus’ > ‘Alterable Values' > ‘Flags' > 'Is a flag off? > 'Flag 0’

Right-click under ‘Bank Check’ > 'Set counter’ > 0 > 'OK’

Click on the words 'New Condition’ > ‘bank check’ > ‘Compare counter to a value' > "Greater” 0 > 'OK’
Right-click on the condition words "0" > ‘Insert’

'Group.Bonus' > ‘Alterable Values' > 'Compare to one of the Alterable Values' >

‘BANK id’ or 'Alterabel Value B' > "Equals”

value("bank check”) > 'OK’

On that row right-click to add an action under 'Player 1’ > 'Add to score’ >
bonus("Group.Bonus”) > 'OK’

Right-click under ‘Group.Bonus' for that row ‘Flags' > ‘Set off > Flag 0’

Right-click under the ‘Info’ string object > ‘Change alterable string’ >
"BONUS! "+Alterable string A("Group.Bonus")+NewLine$+5StrS(bonus("Group.Bonus”))

[Test your game] 2 9




HORROR BA11 - D3) Tilt Alarm

Click on the FRAME EDITOR icon to load the 'Frame Editor’
[Insert an Object] 'Counter’ place off screen

[Rename] 'tilt’

In the ‘Properties Window' select the 'Settings' category set
Inital value:0

Minimum value: 0

Click on the EVENT EDITOR icon to load the 'Event Editor’

In the 'tilt’ group of events, to all 4 tilt conditions (Keybaord press Up,Down,Left Right) add the action by
right-clicking under the 'tilt' counter > 'Add to counter' > RRandom(20,80)

In the group click 'New Conditon’ > ‘the timer' > 'Every’ > 1 1/100ths > 'OK’
Right-click on this conditon to Insert > 'tilt' > ‘Compare to a value' > "Less than” 100 > 'OK'

On the row of that event under 'tilt’ right-click for an action ‘Subtract from counter > 1 > 'OK

Insert a condition on all the event that give score
Insert > 'tilt' > '‘Compare to a value' > "Less than” 100 > 'OK'

This means the conditions will only run if the counter is lower
than the threshold of 100, and once above it'll stay above

On the "new ball” event add an action under 'tilt’ > 'Set counter > Q0 > 'OK’ 3 o



HORROR BA11 - D4) Sound and Artwork

This is complex. so refer to the video.

impactgamers.net/retro/hb
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