ROfI‘O kamakés Micro Driver D3) Music

In the EVENT EDITOR

Find the condition Timer equals 03"-00' (When the race starts)

Add an action by right-clicking under the 'Sound' (Speaker) colomn on the line of that condition.
'Samples’ > 'Play and loop sample' > From a file BROWSE' > "music badoink - fire it up.mp3”
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Find the condition 'Laps of "Group.Vehicles" = 3’

Add an action by right-clicking under the 'Sound’ (Speaker) colomn on the line of that condition.

'Samples' > 'Stop any sample playing' Some events hidden oY i LS
18 | ¢ Timer equals 03"-00 i;ﬂ
@ [Test] 19 | s Lapecf|dal=2 v
[Save] ST ek

Making a good track takes time, change the course, CPU normal speeds,
obstacles and checkpoint positions and keep testing and saving your work.
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This document is part of a series of Clickteam Fusion 2.5 tutorials.
To access the additional video, play the game, download fusion files and assets visit

https://impactgamers.net/retro/micro

Based on Codemasters 1991/94 smash
"Micro Machines" (1 & 2) in this remake
we'll look at replicating some of the
great aspets this console game had to
offer.

impact gamers : inspiring makers
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Load up Clickteam Fusion 2.5

From the top menu select File' > 'New Application’
You are now in the 'Storyboard Editor’

9 [Reusable Skill - Save your game]
From the top menu select File' > 'Save’ (name your file if it's unnamed)

[End Skill]

Select the application from the top of the Workspace Toolbar to load its Properties

, . - , Properties - micro driver A |
From the Properties window select the 'Window' category EEREE IR
Window o
Click and type in the 'Size’' "960" x "560" and press Enter | size 960 x 560 |
| Bordercolor [~ RGB = 255, 255
Style...
When prompted about changing the frame sizes also, click Yes' ,r-"" Heading
| Heading when maximized

Click on the blank white preview of Frame 1 to select it

In the Frame 1 Properties Windows 'Settings’ category change the 'Background Color' to grey or

Similar Properties - Frame 1 a
| | | BB o E
Click on the number '1' on the first frame preview or the [[settings
Frame Editor logo to enter the "FRAME EDITOR" 15_ D””“”C'““E;;gi“;;;
1Ze
Virtal Width (960
Virtual Height | 560
Background color | RGB = 127, 127,127
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[Reusable Skill - Inserting an Object]
From the top bar click 'Insert’ > 'New Object’

Click on Active (Available from 'All Objects’ or 'Graphics and Animation’ category)

Click 'OK’

Click on the frame to drop your object
[End Skill]

v [Reusable Skill - Importing Artwork]
Right-Click on the Object and click 'Edit’ for Image Edito

Find and select the image 'car p1.png’ and click 'OK’

Click 'OK’
[END]

[Reusable Skill - Rename]

% Create new object

All Objects

Android

Background

Data

Games

Graphics And Animations
Html5

Interface

Physics

With the object selected from the Properties window select the

'‘About’ category
Click on the current name and type in "p1"

Press Enter to accept your new name
[End SkKill]

Properties - pl

2
M Backdrop

Button Combo Box

L X |

E %R bHBL

' About
MName
lcon

Cancel

Help

From File(s)

Refresh
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Benle| |
Player Non-physical movements
[ @Static
: ovemen cuncing Ba 4
v [Reusable Skill - Select a Movement] PRI | Tt
With the object selected from the Properties window select the Rotation speed || % Mouse Controlled |
' ' Speed | 4ik Eight Directions
Movement' category i e 1
Deceleration =i Platform
- " . " L) L) L1} 3 n P i I
Click on "Static” next to Type' and select "Physics - Race Car Movement ];bii”:"“""'e’“ "ﬁ"p"’h;,‘::f'j";‘;ﬁzm“mwement
[End Sk]l.l_] Density ' ﬁphysics-Eackgruund !
Friction || B Physics - Bouncing Ball movemnent |
Elasticity Physics - Platform movement
If alerts about Physics Engines or Hotspots appear just press 'OK' Joint |- Physics - Race Car movement
Type | ! Physics - SpaceShip movement

In the 'Properties window' under the 'Movement' category > Set 'Speed’ to "80"
(This is your maximum speed) and Set Elasticity > "33" (% amount you bounce).

| Mowvement

Initial direction | —0°
Rotation speed 520
@ [Insert an Object] Insert a Physics Engine object and place it outside the left side 23
of the frame Deceleration |20
[ Allowreverse
Object )
w. [Reusable skill - Test] Doty £
From the top menu click 'Run’ > 'Frame’ (Or 'Application’, as there is only one | Elasticity 33

frame)

If the window is still open after you have tested your code, close it,
otherwise it will restrict your work in the 'Frame Editor’
[End]

Use the arrow/cursor keys to control the cars movement, UP-accelerate,
DOWN-break, LEFT/RIGHT steering
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Lele [, slLe

[Insert an Object] Insert an "Active” object into the frame
[Import Artwork] 'obstacle post.png’
[Rename] “Post”

[Insert an Object] Insert an "Active” object into the frame |
[Import Artwork] ‘obstacle fork.png’
[Rename] “Fork”

[Insert an Object] Insert an "Active” object into the frame
[Import Artwork] 'obstacle knife.png'
[Rename] “Knife”

[Insert an Object] Insert an "Active” object into the frame
[Import Artwork] 'obstacle pot.png’
[Rename] “Pot”

Select all the new obstacles you added ; (] -

[Reusable skill - Select Multiple Objects]

Hold 'Shift’ on the keyboard and click on all the objects you want to
select/deselect, clicking without holding 'Shift’ will cancel your selection
[End]

% Objects qualifiers

O
[Reusable skill - Add to a Qualifier Group] Obstacies

In the 'Properties Window' select the ‘Events’ category
Click in the blank space next to Qualifier(s) > click 'Edit’' > click 'Add’ > Choose
'‘Obstacle’ > click 'OK' > click 'OK’ [End]
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{ % MNew Condition

‘%dem@ ¢

Start of frame

Click on the 'Event Editor’ icon to go to the EVENT EDITOR

Click on 'New Condition’ > 'Storyboard Controls’ > 'Start of Frame'

Add an action by right-clicking under the '‘Group.Obstacle’' colomn on the line of the condition
you just made.

Group.Obstacles ‘ ‘ ‘ ‘ ‘ ‘ ‘
i
% ,“ ]

Choose ‘Animation’ > 'Paste image into background' > | * Paste into background as obstacle|
Select 'Obstacle’ > click 'OK’ ———

Click on 'New Condition' > 'p1' (Player's car) > 'Collision’ > 'With backdrop'

Add an action by right-clicking under the ‘p1’ colomn on the line of the condition you just

made. —
= LLIII 1
Some events hidden & ¢

N

Choose 'Movement' > ‘Stop’ 2 |+ @ collides with the background ‘

@ [Test] B — ) i : BERCEE 26 P New condition

<8
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Click on the 'Frame Editor’ icon to go to the FRAME EDITOR

We are going to expand our frame area =@ micro driver *
|—l:I Frame 1
Click on 'Frame 1' in the 'Workspace Toolbar’ e p

Properties - Frame 1

In the 'Properties Window' under the 'Settings’ change the Size to "4000" x "2500"

BB Qg
Click on the 'Event Editor’ icon to go to the EVENT EDITOR Settings

[~ Don'tinclude at build time
Click on 'New Condition’ > 'Special' (Cogs) > 'Always' Size 4000 x 2500

Add an action by right-clicking under the 'Storyboard Controls' (Chess board) colomn on the
line of the condition you just made.

Click 'Scrollings’ > 'Centre window position in frame' > 'Relative to' > 'p1’ (Player's Car)

@) Center window posi.. 2 x

@ [Test] «[ ] o[ ]

(O) At actual X,¥ coordinates

Layer :
@ Relative to: [l 1

Options

Cancel Help
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® (1, ®

Click on the 'Frame Editor' icon to go to the FRAME EDITOR

We are going to add the table for racing on

[Insert an Object] Insert an "Active” object into the frame
[Import Artwork] 'table.png’

[Rename] “Table”

[Insert an Object] Insert an "Active” object into the frame
[Import Artwork] 'bridge.png’
[Rename] “Bridge horz” (for horizontal, we'll be making a vertical version later)

[Mulitple Select Objetcs] Select the 'Table' and 'Bridge horz' objects
[Add to a Qualifier Group] Add to the 'Area’ group

[Reusable Skill - Clone]

Right-click on 'Bridge Horz' and click 'Clone’, leave the settings as 'rows:1, colomns:2' and
click 'OK'

[End]

Edit
Insert Object
Lock

Rename

This new cloned object is identical but with different name i.e. 'Bridge Horz 2 mamilbiec

Right click on 'Bridge Horz 2" and click 'Edit’, click on the Rotate 90 tool and click 'OK’
[Rename] to 'Bridge Vert'

From the 'Asset toolbar’ add in objects to make a track.

ITip! Use the Grid setup, Zoom 25% and the Tools>Arrange functions to help you build the
course
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[Insert an Object] Insert an Active Object (In cateogry 'All Objects’ and 'Graphics and Animation’)
[Import Artwork] “car cpu2.png” (make sure Hotspot & Action Point are set to center)

Animations

Still in the Image 'Edit’ window select the 'Animation’ 'Falling’ e
[Import Artwork] “respawning_01.png” and select 'Import as Animation’ Walling

# B 2 : Running
Click 'OK' to return to the Frame Editor Agpesniid
Disappearing
Bouncing

[Rename] 'cpu 2" (CPU is how retro games named the computer opponents) | tencing

Jumping

® ® [|,®

- Properties - cpu 2

[Select a Movement] Type' > 'Physics - Bouncing Ball movement’ > | G
Initial Direction: Reset and inly tick direction 0 (right) | Movement
Set Elasticity: 35 T{”"Emfnf i"".‘“;:"‘?""_“: _
Set Gravity Scale: 0 e ekt ot
Set Initial Speed: 0 MEYEEOR
Set Collision Shape: ‘First Image’ initial speed |0

Deceleration |0
[Clone] Clone the 'cpu 2' car, with options "Rows 1, Colomns 3" S:I::;:t;r 33{:

Friction |
For objects 'cpu 3" and 'cpu 4' [Import Artwork] “car cpu3.png” and "car cpu4.png” 2?:;:2:3'& 35

We are going to place multiple objects into Qualifier Groups

[Select mulitple objects] Select 'p1’, ‘cpu 2', ‘cpu 3" and 'cpu 4'
[Add to a Qualifier Group] 'Vehicles'

® ® [,®

[Select mulitple objects] Select just ‘cpu 2', ‘cpu 3" and ‘cpu 4' il ¥
[Add to a Qualifier Group] 'NPC' (non-playerable characters)




Refl‘ﬂ ROMkOS Micro Driver B1) Opponents 2/2

Click on the 'Event Editor" icon to go to the EVENT EDITOR Lﬂw e

Insert hidden object

Insert object folder

Right click on the 'p1' car icon on the top row and select 'Replace by another object’
Chose the 'Group.Vehicles' and click 'OK’

Replace by another object
When the warning appears saying This action cannot be undone. Do you want to continue’ click 'OK’
Click on 'New Condition' > 'Group.Vehicles' > 'Collision’ > 'With another object’ > 'Group.Vehicles' > 'OK'

Add an action by right-clicking under the 'Group.Vehicles' colomn on the line of the condition you just
made.

Choose 'Movement' > 'Stop'

To check when the cars are not on the table we need to run a count (special looping through each
instance of an object)

On the 'Always’' row, under the ‘Group.Vehicles' right-click to add an action
‘Count’ > 'For each object’ and set the name to "falling” (include the double quotation marks) > 'OK’

Click on 'New Condition’ > '‘Group.Vehicles' > '‘Loops' > 'On each object’ > "falling” > 'OK’
Right-click on the words in the new conditon 'On each one of" and click ‘Insert’
‘Group.Vehicles' > 'Collisions’ > '‘Overlapping an object’ > 'Group.Areas’ (The table) > 'OK’

Right-click on the words "Is overlapping” and chose 'Negate' to make a X appear

@ Add an action by right-clicking under the '‘Group.Vehicles' colomn on the line of the
condition you just made. Choose 'Destroy’ [Test] & [Save]
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&

Click on the 'Frame Editor' icon to go back to the FRAME EDITOR ?Lgé

[Insert an Object] Insert an 'Active’ object ;Qﬂ o

[Rename] 'Checkpoint’ g '

Right-click on the 'Checkpoint’ object and click 'Edit’ for the Image Edit screen. lzg”

Click on white piece of paper logo to 'Clear' the image Q|_O

Pick a bright colour and using the 'Elipise Tool' (E) with 'Filled' option jm'l Bl ;1 WEEE —
Drag out a circle filling the available space Eﬂ | B —ws Fae
Click 'OK' m e

Click on the 'Checkpoint’ object and wait before clicking again until the resize boxes appear.
Stretch the object to be large, just over half the height of the frame.
Drag and position the 'Checkpoint’ object behind the cars.

In the 'Properties Window' under the 'Display Options' category
set the Blend Coefficient: 200

From the Asset bar, drag and drop checkpoints all around the track in reverse order,
try not to get them to overlap much.
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In the 'Properties Window' for the 'Checkpoint’ in the 'Values' category I T
Click 'New' and double-click on the title 'Alterable Value A’ and change it's name to 'Number’ ke B

Values
Click on the 'Event Editor' icon to go back to the EVENT EDITOR [y

On the row 'Start of Frame' right-click under the 'Checkpoint’ colomn.

'‘Alterable Values' > 'Spread Value' > 1 > OK (This will count up from 1 setting the 'Number' value as it goes)

Click on the 'Frame Editor' icon to go back to the FRAME EDITOR

Properties - Multiselection
@ [Select Mulitple Objects] 'p1’, 'cpu 2', 'cpu 3" & ‘cpu 4' % B =
| Values

In the 'Properties Window' in the 'Values' category we are going to add some new T

alterable values, name them and set a value going to 1

coming from 1
Under 'Alterable Values' click 'New', then double-click the name to rename, laps 0
and click on the 0 to set the value normal speed | 0
Alterable Value A > going to: 1 control 0
Alterable Value B > coming from: 1 | last angle 0

Alterable Value C > laps: 0
Alterable Value D > normal speed: 0
Alterable Value E > control: 0
Alterable Value F > last angle: 0

For each cpu car individually set the 'normal speed’ alterable value between 50 and 80
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Click on the 'Event Editor’ icon to go back to the EVENT EDITOR
Click on 'New Condition' > 'The Timer' > 'Every' > 0 :Hours, 0 :Minutes, 0 :Seconds, 1 :1/100th Sec > 'OK’
Add an action by right-clicking under the 'Group.NPC' colomn on the line of the condition you just made.

Choose 'Count’ > 'For each object’ > "aim” (include the double quotation marks) > 'OK’

Animation >
| Pick or count >
I Visibility > Help
Click on 'New Condition' > 'Group.NPC' > 'Loops' > b :
»

i . i 0o - ' ¥ L Q h ahject
On each object’ > "aim" > 'OK oops n each obje

Compare to fixed value I

Right-click on the words in the new conditon 'On each one of' and click 'Insert’
'‘Checkpoint’ > 'Alterable Values' > '‘Compare to one of the alterable values’' > 'Number' 'equal to' and change 0
to going to("Group.NPC")

Add an action by right-clicking under the ‘Group.NPC' colomn on the line of the condition you just made.
Choose 'Direction’ > 'Look in direction of' > 'Relative to' > 'Checkpoint’ > 'OK’
Add another action by right-clicking under the 'Group.NPC' colomn on the
action tick you just added

Choose ‘Movement' > ‘Physics’ > 'Set Linear Velocity' >
normal speed("Group.NPC") > 'OK' > angle("Group.NPC") > 'OK'




Refl‘ﬂ R’mak“ Micro Driver B3) CPU driving 3/3

Click on 'New Condition’ > 'Group.Vehicles' > 'Collision’ > 'With another object’ > 'Checkpoint’ > 'OK’

Right-click on the words in the conditon 'Collision between' and chose 'Insert
‘Checkpoint’ > 'Alterable Values' > 'Compare to one of the alterable values' > 'Number' 'equal to' and change 0
to going to("Group.Vehicles")

Add an action by right-clicking under the 'Group.Vehicles' colomn on the line of the condition you just made.

Choose 'Alterable values’ > 'Set’ > Change value selected to 'Coming from' where the value 0 is change this to
going to("Group.Vehicles") > click 'OK’

Add another action by right-clicking under the 'Group.Vehicles' colomn on the action tick you just added

8 Compare to one of the alterable values

Choose ‘Alterable values’ > 'Add to' > ‘Going to' and change the value to 1 > 'OK’

Choose value
going to

Click on 'New Condition’ > 'Group.Vehicles' > 'Alterable Values' >

Choose comparison method:

‘Compare to one of the alterable values' > Greater
‘Going to' is 'Greater than' NObjects("checkpoint”) > S 7 B
'0K' ==

]HOhjects{ "checkpoint"

Add an action by right-clicking under the 'Group.Vehicles' colomn on the line of
the condition you just made.
Choose 'Alterable values' > 'Add to' > 'Laps’ and change the value to 1 > 'OK’

Add another action to ‘Group.Vehicles' ontop on the previous one
Choose ‘Alterable values’ > Set’ > 'Going to' and change the value to 1 > 'OK’

@ [Test] Reposition obstables or checkpoints to mkae things work well [Test] again [Save]
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Properties - Multiselec.., 3 E2

CIESSEYE]] =

Click on the 'Frame Editor' icon to go back to the FRAME EDITOR f:?,'_:_f;l_ﬂa._u_e_s
going to 1
@ [Select Mulitple Objects] '‘p1’, 'cpu 2', ‘cpu 3' & 'cpu 4' :f;:mgfmm ﬁ::

normal speed |
| control |0

In the 'Properties Window' in the 'Values' category we are going to add a new flag

| last angle |0
: [ Mew
| Alterable Strings

Under 'Flags’, Click 'New', then double-click the name to rename and call it "respawn” New

| Flags
[T respawn

Click on the 'Event Editor' icon to go back to the EVENT EDITOR |[_New

Find the line/row for condition 'X "Group.Vehicles" is overlapping "Group.Area™
On that row right-click on the action tick under the Group.Vehciles colomn ('Destroy’)
Delete’ that action tick

¢ On each one of \&. , loop name

5 "falling" /

+ X :a‘ is overlapping ‘ o
Berie | Destroy |

Right-click on the same square to add a new action
Flag' > 'Set on’ > ‘'respawn’ > 'OK’

¢ On each one of |h‘ , loop name
5 | ‘"falling" —
. X :h, is overlapping | .

= 0z Set respawn on
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Click on 'New Condition’ > 'Group.Vehicles' > 'Collision’ > 'With another object’ > 'Checkpoint’ > 'OK’

Right-click on the words in the conditon 'Collision between' and chose ‘Insert’
'‘Checkpoint’ > 'Alterable Values' > ‘Compare to one of the alterable values' >
'Number' 'Different’ and change 0 to going to("Group.Vehicles")

Again right-click on the words in the conditon 'Collision between’ and chose ‘Insert’
'‘Checkpoint’ > 'Alterable Values' > '‘Compare to one of the alterable values' >
‘Number' 'Different’ and change 0 to coming from("Group.Vehicles")

s |
¢ Collision between ‘kl and .JI

Add an action by right-clicking under the 'Group.Vehicles' ol e gfl. S I&;li)

colomn on the line of the condition you just made. r L |
+ Number of :.. <> coming from( " Ihﬂ )

'Flag' > 'Set on’ > respawn’ > 'OK’
Click on 'New Condition’ > 'Group.Vehicles' > 'Alterable Values' > 'Flags’ > 'is flag on' > 'respawn’ > 'OK’

Add an action by right-clicking under the i . ‘r C B EE
'‘Group. Vehicles' colomn on that line el da s respawn s on \/‘ SltSpJEdtJD‘ ‘ ‘ ‘ ‘

¢ Change animation sequence to Falling

'‘Movement' > 'Set speed’ > 0 > 'OK’
Add another action to that square for 'Group.Vehicles'

'‘Animation’ > '‘Change Animation Sequence’ > 'Falling’ > 'OK’
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Click on 'New Condition’ > 'Group.Vehicles' > 'Animation’ > 'Has an animation finished' > 'Falling’ > 'OK’

Add an action by right-clicking under the ‘Group.Vehicles' colomn on the line of | ‘ S
the condition you just made. e Set position at (0,0) from .
¢ Setspeedto0

Right-click on the words in the conditon 'animation Falling is over' and chose ‘Insert’
‘Checkpoint’ > 'Alterable Values' > ‘Compare to one of the alterable values’
‘Number' ‘'equal to’ and change 0 to coming from("Group.Vehicles") /‘

'Position’ > 'Select position’ > 'Relative to’ > 'Checkpoint’ > 'OK’

Click on 'New Condition’ > 'Group.Vehicles' > 'Animation’ > 'Has an animation finished' > 'Falling’ > 'OK'

On the same action, right-click to add another action ¢ Lookat (0,0) from .

'‘Animation’ > 'Change’ > 'Animation sequence’ > 'Stopped’ > 'OK’ ¢ Set respawn off
¢ Change animation sequence to Stopped

Right-click on the words in the conditon 'animation Falling is over’ and chose ‘Insert’
'‘Checkpoint’ > 'Alterable Values' > ‘Compare to one of the alterable values’
‘Number' 'equal to' and change 0 to going to("Group.Vehicles") ‘/‘

'Direction’ > 'Look in direction of' > 'Relative to' > '‘Checkpoint’ > 'OK’

Finally on the same action, right-click to add a third action
@ 'Flags'> 'Set off' > 'Respawn’ > 'OK’
[Test] Move any checkpoints that are causing issues

In the 'Workspace Toolbar' or the 'Assets bar' click on the 'Checkpoint’ icon
In the 'Properties’ 'Display Options' category uncheck 'Visible at start’ [Save]
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Click on the 'Frame Editor' icon to go to the FRAME EDITOR
We are going to add some counters to the game, one for laps another for time.
Open the 'Layers Toolbar' by clicking on the Layers Toolbar tab on the right hand side of the frame.

. . . _ _ " LayersTool.. + B
ITip! If the Layer Toolbar is not available reactivate it from the top menu

View' > Toobars' > 'Layer' (or press Control+K)
Click the white piece of paper to create a new layer.

Uncheck the eye logo on layer 1, so that layer is hidden.

With Layer 2 selected, In the 'Properties Window' change the X and Y coefficient to 0
(This means this layer will scroll at 0%, so not scroll at all)
You can also rename the Layer to "HUD" (heads up display) or "GUI" (graphichal user interface)

[Insert an object] Insert a 'String’ object to the top left

In the 'Properties Window' in the 'Settings’ category change the 'Paragraph’ to have the value "Time"
@ In the 'Properties Window' in the Text Options' category change the 'Font’ to the font and size you want

[Rename] "Title Time"

@ [Clone] This string and move it below
In the 'Properties Window' in the 'Settings' category
change the 'Paragraph’ to have the value "laps”
[Rename] "Title Laps”
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@ [Insert an object] Insert a 'Counter’ object under Title Time'
In the 'Properties Window' in the 'Settings' category change the Type' to 'Numbers'
In the 'Properties Window' in the Text Options' category change the ‘Font’

@ to the font and size you want
[Rename] "Time"

@ [Clone] This counter and move it below Title Laps'
[Rename] "Laps”

On the 'Layers Toolbar' select Layer 1 (The Game) and click the Lock icon on Layer 2 (HUD/GUI) to stop it
from being edited

Click on the 'Event Editor' icon to go back to the EVENT EDITOR

6 |L' Every 00°-01 H J I
i | - |_ | - Add 1 to Counter

| « Oneach nne nfiﬁm.

Find the condition 'Every 00"-01" (Every 1/100th second)

On that row under the Timer' counter colomn, right-click and add the action
'‘Add to counter’ > and change the value to 1 > 'OK’

Find the condition 'Always'’
On that row under the 'Laps’ counter colomn, right-click and add the action

‘Set counter’ > and change the value to laps("p1") > 'OK'
All the events abc E!

== — 1= o = m
3 | =« Always ‘

—
Set Counter to laps( " l- "3
|

| ¢ Collision between !h‘
4 | T —
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Click on the 'Frame Editor icon to go to the FRAME EDITOR LA

Open the 'Layers Toolbar' by clicking on the Layers Toolbar tab on the right hand side of the frame.

Click the white piece of paper to create a new layer.

Click and drag this new layer (3) under all the other layers (1)

With the new layer (1) selected, In the 'Properties Window' change the X and Y coefficient to 0.7
(This means this layer will scroll at 70%, so not as quickly as the game layer)

You can also rename the Layer to "Floor" i o MReE -

Iwaah o

@ [Insert an object] Insert a 'Quick Backdrop' object (Not '‘Backdrop’) to the top left e —
In the 'Properties Window' in the 'Settings’ category change the Type' to ‘Motif’ | Moti [ _Edit ]

In the 'Properties Window' in the 'Settings’ category under 'Motif' click 'Edit’
[Importing Artwork] Import the image "bg floor.png"
[Rename] "Floor”

In the 'Properties Window' in the 'Size/Position’ category change the values

X: 0 Properties - Floor a |
Y: 0 ] B W
Width: 4000 gﬁt{o:osﬂm
Height 2500 X :
Size :
& rres e

It should now fill the layer and when in game move slower than the other layers
This different speed makes it seem to be at a different depth, this is called parallaxing
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Still in the FRAME EDITOR

Open the 'Layers Toolbar' by clicking on the Layers Toolbar tab on the right hand side of the frame.

Click the on the top layer (3) with the Timer and Laps
Uncheck the lock icon to unlock it -
[Insert an object] Insert a 'String’ object to the center of the screen boundary

In the 'Properties Window' in the 'Settings’ category change the 'Paragraph’ to have the value "GET READY"
In the 'Properties Window' in the Text Options' category change the 'Font' the font and size you want and align

it to 'Center’
@ [Rename] "Info"
Click on the 'Event Editor' icon to go back to the EVENT EDITOR
Click on 'New Condition’ > 'Info’ (The String you just added) > 'Visibility' > 'If “Info" is visible'

Add an action by right-clicking under the ‘Player 1" (Jovstick icon) colomn on the line of the condition you just

made' o Score > ‘ ; ‘
Mumber of Lives ¥
Player Control > lgnore Cantrol
'Player Controls' > 'Ignore Controls’ SE—— S—" k

On the same line add an action by right-clicking under the 'Group.Vehicles' colomn

'Movement' > 'Set Speed' > 0 > 'OK'
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Now for when it's invisible
Click on 'New Condition’' > ‘Info’' > 'Visibility' > 'If "Info" is invisible'

Add an action by right-clicking under the 'Player 1" (Joystick icon) colomn on the line of the condition you just
made. ‘

All the events | (; %EE ‘1- | I :

: | ' | Pyer 1] | F i
« @bg, is invisible H ‘ ‘ | ‘ ‘ ‘

Restore Control |

'Player Controls' > 'Restore Controls'

@ [Test]

é‘ ~ IBug! The timer starts before the race begins, and the other cars have changed their directions

15

16 | » Timer equals 01"-00

Find the condition 'Every 00"-01" (Every 1/100th second) e Every 00"-01

S E is invisible

Right-click on the words and chose 'Insert’
'Info’ > 'Visibility' > 'If "Info" is invisible'

@ [Test] The events work well, now we need to countdown to the start of the race

Click on 'New Condition’ > 'The Timer' > 'Is the timer equal to a certain value' > 1 second (0 for all others)
Add an action by right-clicking under the 'Info' (String) colomn on the line of the condition you just made.
‘Change alterable string’ > "SET" (Leave in double quotation marks) > 'OK'
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Click on 'New Condition' > 'The Timer' > 'Is the timer equal to a certain value' > 2 seconds (0 for all others)
Add an action by right-clicking under the 'Info’ (String) colomn on the line of the condition you just made.
‘Change alterable string’ > "GO!" (Leave in double quotation marks) > 'OK’

Click on 'New Condition' > 'The Timer' > 'Is the timer equal to a certain value' > 3 seconds (0 for all others)
Add an action by right-clicking under the ‘Info’ (String) colomn on the line of the condition you just made.
'Visibility' > 'Make Invisible' > 'OK’

Click on 'New Condition’ > 'Group.Vehicles' > 'Alterable Values' > '‘Compare to one of the alterable values’
> 'Laps’ 'Equal’ 3 > 'OK’

Add an action by right-clicking under the ‘Info’ (String) colomn on the line of the condition you just made.

‘Change alterable string’ > OName("Group.Vehciles")+" wins, press R to restart” (Leave in double quotation

marks) > 'OK’
Add another action to the same action you just made B eyt ek
'Visibility' > 'Make Visible' > 'OK’ I B T S

|0Na.me$l.' "Group.Vehicles" ) + " wins, press R to restart”

Click on 'New Condition’ > 'The Mouse Pointer and Keyboard' > 'The Keyboard' > 'Upon pressing a key' > "r"

Add an action by right-clicking under the 'Storyboard Controls' (Chess board)
colomn on the line of the condition you just made.
‘Restart the application’

@ [Test] [Save]
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Click on the 'Event Editor’ icon to go back to the EVENT EDITOR

Find the line which has the condition 'Collision between "Group.Vehicles" and "Group.Vehicles™

Right-click on the "Group.Vehicles" colomn on that line, ontop of the action tick that is already there
"Alterable Values' > 'Add to' > 'Control’ 13 (or any number between 10-20)

This is how long they will lose control for in 1/100ths of seconds after a collision

Find the line which has the condition 'Every 00"-01' (Every 1/100th second)

Right-click on the "Group.Vehicles" colomn on that line Some events hidden oy . gy W“’J. 7
"Alterable Values' > 'Subtract’ > 'Control’ 1 e Every 00"-01 | [Gowevehces] [ | |
+ @' is invisible ‘/ /

This is for them to regain control

’ — Sub 1 from control |
14 | ¢ [@be ic visihle | |adl , ; :

Click on 'New Condition' > 'Group.Vehicles' > ‘Alterable Values' > 'Compare to one of the alterable values' >
‘Control’ ‘Lower’ 0 > 'OK’

Add an action by right-clicking under the ‘Group.Vehicles' colomn on the line of the condition you just made
"Alterable Values' > ‘Set’ > ‘Control’ 0

Find the line which has the condition 'On each one of "Group.NPC", loop name "aim™
Right-click on the words "On each one of" and chose ‘Insert’

‘Group.Vehicles' > 'Alterable Values' > ‘Compare to one of the alterable values’ >
‘Control’ 'Lower or equal’ 0 > 'OK’

@ [Test]
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Click on the 'Frame Editor' icon to go to the FRAME EDITOR m

@ [Inserting an Object] Insert an 'Active’ object above your frame

[Importing artwork] Import 'skid.png’ .
[Rename] 'skid’ m

We are going to expand the use our falling count loop for the Group.Vehicles
Click on 'New Condition’ > '‘Group.Vehicles' > 'Loops’ > 'On each object’ > "falling” > 'OK’

Right-click on the words in the new conditon 'On each one of' and click ‘Insert’
'Special’ (Cogs) > 'Compare two general values' >
In the top 'Enter expressions and choose the comparison method...' box write

Abs(Angle( "Group.Vehicles” ) - last angle( "Group.Vehicles" ))

Then select '‘Greater' and in the bottom box put 20 > 'OK’ * Oneachaone of 'g‘ , loop name “falling"
22 | + Abs(Angle( " h‘ ") - last angle( " 'h‘ ")) > 20
Again right-click on the words in the new conditon . Abs(Angle( " E ") - last angle( " _g ")) < 90

‘On each one of' and click 'Insert’

'Special’ (Cogs) > 'Compare two general values' >

In the top ‘Enter expressions and choose the comparison method...' box write
Abs(Angle( "Group.Vehicles" ) - last angle( "Group.Vehicles" ))

Then select 'Lower’ and in the bottom box put 90 > 'OK’

This abs function is giving us the positive value of the difference between the cars
angle and the last angle variable
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On that line with the large condition you have made right-click under 'Create new objects’ (Shiny box) colomn
‘Create object’ > 'skid' > 'OK' > 'Relative to' > 'Group.Vehicles'

On the same line under the 'skid' colomn
'Scale / Angle' > 'Set Angle’' > Angle( "Group.Vehicles" ) > 'OK’

This will set the angle of the skid to match the car, now we need to use the ‘last angle’ variable

Click on ‘New Condition’ > 'The Timer' > 'Every’ > B S .

0 :Hours, 0 :Minutes, 0 :Seconds, 20 :1/100th Sec > 'OK’ ERETCI |
['3' |Minute{s} .

|':I |Sec0nd{s} .

Add an action by right-clicking under the (2 Jurso0 ]
‘Group.Vehicles' colomn on the line of the Use a calcaton
condition you just made. = = -

‘Alterable Values' > 'Set’ > 'Last angle’ Angle( "Group.Vehicles" )

B 1T 1 [

Set last angle to Angle( " |h‘ "y [

@ [Test]

/‘#4 Bug! The skid marks go over the car and when too many appear it glitches the game
“ To resolve this we will cause them to fade away and cars to appear above them
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&

In the EVENT EDITOR

Click on 'New Condition' > 'The Timer' > 'Every' >
0 :Hours, 0 :Minutes, 0 :Seconds, 1 :1/100th Sec > 'OK’

Add an action by right-clicking under the 'Skid' colomn on the line of the condition you just made.
‘Alterable Values' > 'Add to' > 'Alterable value A" 1
(we can rename this value in the object properties to "fade” to help us remember what it is if we want)

v [T [

¢ Add 1 to fade ,
¢ Set alpha-blending coefficient to fade( " = ")

Add another action by right-clicking under the 'skid’ colomn on the line on the same action.
'Effect’ > 'Set alpha-belnding coefficient’' > Alterable Value A( "skid" )

Click on 'New Condition’ > 'skid' > 'Alterable Values' > 'Compare to one of the alterable values' >
‘Alterable Value A’ 'Greater’ 255

An alpha-belnding coefficient of 255 is totally transparent, 0 is solid

Add an action by right-clicking under the 'skid’ colomn ”
on the line of the condition you just made. 25 | o Fade 0f|: > 255 H “/‘ ‘

‘Destroy’ | |
26 | « New condition W

Find the 'Always’ condition and add two action one under 'Group.Vehicles' the
other on 'Group.Obstacles’ '‘Order’ > 'Bring to Front’
[Test] [Save]




