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. . . . . . impact gamers : inspiring makers
This document is part of a series of Clickteam Fusion 2.5 tutorials.
To access the additional video, play the game, download fusion files and assets visit

https://impactgamers.net/retro/rv
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Based on Konami's 1994 run
and gun game
Contra/Probotector: Hard
Corps in this remake we'll
look at replicating some of
the great aspects this console
game had to offer.
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Robovenger Player (Physics - Platform)

Load up Clickteam Fusion 2.5

From the top menu select 'File' > 'New Application’

You are now in the 'Storyboard Editor’

[Reusable Skill - Save your game]

From the top menu select ‘File' > 'Save’ (name your file if it's unnamed)
[End Skill]

Select the application from the top of the Workspace Toolbar to load its Properties
From the Properties window select the 'Window' category

Click and type in the 'Size’ "864" x "480" and press Enter

When prompted about changing the frame sizes also, click 'Yes'

Click on the number 1" on the first frame preview or the

Frame Editor logo to enter the "FRAME EDITOR"

Click on the "Grid Setup” from the top bar and set

height: 32

width: 32

Snap to: Checked
Show grid: Checked , click "OK"



Robovenger A1) Player (Physics - Platform)

[Reusable Skill - Inserting an Object]
From the top bar click ‘Insert’ > 'New Object’

Click on Active (Available from ‘'All Objects’ or ‘Graphics and Animation’ category)

Click 'OK'

Click on the frame to drop your object
[End SKill]

[Reusable Skill - Rename]
With the object selected from the 'Properties
window' select the 'About’ category

Click on the current name and type in "Player”

Press Enter to accept your new name
[End Skill]

In the ‘Properties window' click on 'Size and Position’

Set the Height: 64

Press ENTER or click off the number
to change the size

o4
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Robovenger A1) Player (Physics - Platform)

[Reusable Skill - Select a Movement]
With the object selected from the Properties window select the
‘Movement' category

Click on "Static” next to Type' and select "Physics - Platform movement”
[End SkKill]

If alerts about Physics Engines or Hotspots appear just press 'OK'

[Insert an Object] Insert a Physics Engine object and place it outside
the left side of the frame

Click on the 'Player’ object to select it. In the ‘Properties windows' select the
‘Movement Properties’ category, and change the settings

Speed: 150
Acceleration: 20
Deceleration: 150
Climbing speed: 10

Use acceleration when changing directions: Checked
Speed when crouched: 0
Allow crouch: Checked
Strength: 80

Multiple Jump: 2

Next Strength: 40
Gravity Scale: 500

05
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Robovenger A2) Backdrop Obstacles & Default Keys

[Reusable skill - Test]
From the top menu click ‘Run’ > ‘Frame’ (Or ‘Application’, as there is only one
frame)

If the window is still open after you have tested your code, close it,
otherwise it will restrict your work in the 'Frame Editor’
[End]

IBug! The player will fall off screen, as we haven't added any floors and
platforms yet

[Inserting an Object] Insert a Backdrop object,
position it below the ‘Player’ object

[Rename] 'Floor’

[Reusable Skill - Importing Artwork]
Right-Click on the Object and click 'Edit’ for Image Editor

Find and select the image ‘floor.png’ and click 'OK’

Click 'OK’
[END]

[Reusable Skill - Change backdrop type]
In the 'Properties Window' select the 'Runtime options’ category

Click on type and select the option "Obstacle”

[END] o 6
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Robovenger A2) Backdrop Obstacles & Default Keys

[Test]

IBug! The '‘Player’ will fall off the screen/frame, as we haven't the events for backdrop
collisions.This one event will handle all the backdrop collisions (platforms, ladders,
obstacles)

Click on the EVENT EDITOR icon to enter the 'Event Editor

Click on ‘New Condition’ > 'Player’ object (Not Player 1 joystick) > ‘Collisions’ > 'Backdrop’
Right click under the ‘Player’ object on that event line

Click ‘Movement’ > 'Stop’

[Test] Make sure the 'Floor' is under the 'Player’

"~ 1Bug! The 'Player’ lands half way through the 'Floor'. This is an issue unique to the 'Platform

movement'. All 'Hot spots’ for that movement need to be at the feet/base of the object.
Click on the FRAME EDITOR icon to enter the 'Frame Editor’
Right click on the 'Player’ object and click 'Edit’

[Reusbale Skill - Hot Spot Position]

While in the Image Editor/Edit view, click on the 'Eye Logo’
to see the 'Hot Spot’ (Rotation and reference point)

Click on the bottom middle square of the Quick Move,

then close the window by clicking 'OK' [End Skill] o 7



Robovenger A2) Backdrop Obstacles & Default Keys

ﬁ [Test] It should work correctly now. Use ARROW KEYS to move and SPACE to jump,
we will set these to be W,A,S,D and SPACE

(Making sure the test window is closed)

Click on the Application logo in the 'Workspace Toolbar’ to select it
In the 'Properties Window' select the 'Runtime Options' category
Scroll down and click on 'Default Controls' > 'Edit’

Click on the X' (or tick) in the 1:Keyboard square to load the keybaord setup
Change the input for

Up: W

Down: S

Left: A

Right: D

Button 1: Space bar

Click 'OK'

ﬁ? [Test] Test the new controls



Robovenger A3) Background Platforms & Paint Mode

Yﬁ [Inserting an Object] Insert a Backdrop object,
position it above the ‘Player’ object

[Rename] 'Platform'’

[Importing Artwork] 'platform.png’

[Change backdrop type] ‘Platform’

[Reusable Skill - Quick Duplicate]

On the keyboard hold CONTROL (CTRL) and drag the ‘Platform Object’ to make a copy
of it above the first

[End Skill]

[Test] Try to jump through the platforms. Adjust the heights if needed

e »5 0

[Reusable Skill - Paint Mode]
To add more 'Platform’ and 'Floor’ objects quickly we will use ‘Paint Mode'

Click on the Pencil icon on the Top bar’ to turn it on
Select an object from the 'Asset Bar' (Floor or Platform)
Click and drag to add the objects to the frame ﬁ

Right click to cancel Paint Mode, select and delete any mistakes [End Skill] [Test] o 9
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Robovenger A4) Active Physics Obstacles

We are going to add some obstacles that can be pushed around the level

[Inserting an Object] Insert an ‘Active’ object above a platform
[Rename] 'Barrel’
[Importing Artwork] ‘barrel.png’

[Reusable Skill - Select a Movement] Physics - Static movement
(Click "OK" if it reminds you to position the hot spot in the centre)

[Reusbale Skill - Hot Spot Position] Click ‘G’ for gravitaional centre

[New Skill - Add to a Qualifier group]
In the 'Properties Window' select the 'Events’ category

Click in the blank space next to Qualifiers row > 'Edit’ > 'Add’

Select 'Obstacles’ click 'OK' to close the add window (Note:
they are not in alphabetical order, Obstacles is quite low down)

Click 'OK' to close the Qualifiers window.
[End Skill]

[Add to a Qualifier group] Add the 'Player’ object to
the "Obstacles’ group too

10



Robovenger A4) Active Physics Obstacles

We are going to apply some events for the '‘Obstacles’ group
Click on the EVENT EDITOR icon to enter the 'Event Editor’
We change the first condition to relate to the 'Obstacles’ group

Right click on the 'Player’ object icon on the heading row >
Replace by another object > ‘Group.Obstacles’ > 'OK' >
Warning this action cannot be undone 'OK’

This will mean all objects in 'Obstacles’ group will not fall through the back drops.

Click on 'New Condition’ > '‘Group.Obstacles’ > ‘Collisions’ > 'Another object’ > 'Group.Obstacles’
> 'OK’

Under the 'Group.Obstacles’ colomn on that event row right click for an action
‘Movement’ > 'Stop’

[Test] Run into the barrel, enjoy. For EVEN more fun use the Paint Mode to add more barrels

[Reusable Skill - Save]

From the top menu bar

'File' > 'Save'

Name your game and press 'OK'
[End Skill]

117
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Robovenger B1) Add Enemies and Values

Click on the 'Frame Editor’ icon to go to the FRAME EDITOR

[Inserting an Object] Insert an 'Active’ object,

[Rename] "Enemy 1"

[Importing Artwork] "enemy 1.png” (Not as animation)

[Reusable Skill - Animation Directions]

While in the image 'Edit’ view

Right click on the black square next to the right arrow and click 'Create opposite direction’
[End Skill]

[Add to a Qualifier group] 'Enemies’

In the 'Properties Window' select the 'Values' category
Set up these values (Double click to change names and values)

Alterable Value A = health : 10

Alterable Value B = explosion damage : 25
Alterable Value C = shoot chance : 100
Alterable Value D = shoot calc : 0

12



Robovenger B1) Add Enemies and Values

With '‘Enemy 1’ still selected (click to select it)

ﬁ [Add to a Qualifier group] ‘Breakable’

Now select the 'Barrel’ (click to select it)

ﬁ [Add to a Qualifier group] ‘Breakable’

In the 'Properties Window' select the Values' category
Set up these values (Double click to change names and values)

Alterable Value A = health : 5
Alterable Value B = explosion damage : 60



Robovenger B2) Enemies Shooting

[Inserting an Object] Insert an 'Active’ object

[Rename] "Enemy Bullet"

[Import Artwork] ‘bullet.png’
Click on the EVENT EDITOR icon to load the 'Event Editor'

[Reusable Skill - Add a Group of Events]
- Click on the number of the row where you want to add the new event group.

In this case it will be at the bottom of the line of events.
From the Top Menu’ click on ‘Insert’ > 'New Group’

Name the title of the group "Enemies” click 'OK’
[End Skill]

Click on New condition in that new group > 'Special’ > "Always’
Under the Group.Enemies on that line, right click to add an action
'Direction’ > 'Look in the direction of' > 'Relative to' > 'Player' object

Click and drag the square target from the hotspot at their feet
to where there 'Player’ object's chest would be.

Click 'OK'

14
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Robovenger B2) Enemies Shooting

Click on 'New condition' > 'The Timer' > 'Every' > 0:Hour(s), 0:Min(s), 0:Second(s), 1:1/100 > 'OK’

Rick click to add an action under the '‘Group.Enemies’ colomn of that event row,
‘Alterable Values' > 'Set’ > Select 'Shoot calc’ (Not 'Shoot Chance’) enter in the
'Expression Editor' Random(shoot chance("Group.Enemies”)) > OK

Click on ‘New condition’ > ‘Group.Enemies’ > 'Alterable Values' >
‘Compare to one of the alterable values "> select the 'Shoot calc’
(Not 'Shoot chance’) in the 'Expression Editor' 1 > OK

Add an action under the 'Group.Enemies’ colomn of that event row by right-clicking, '‘Launch an Object...’

‘Enemy Bullet’ > 'OK’ > leave the speed and direction options as they are and click 'OK’

[Test] Check the enemy shoots at you, alter the '‘Enemy 1’ 'Shoot chance’ if needed
Bug! Bullets have no effect currently

Click on ‘New condition’ > 'Enemy Bullet’ > 'Collisions’ > '‘Backdrop’
Right click under the 'Enemy Bullet' colomn of that event row, 'Destroy’

Similarly for the physics obstacles; Click on 'New condition’ > 'Enemy Bullet' >
‘Collisions’ > '‘Group.Obstacles’

Right click under the 'Enemy Bullet' colomn of that event row, 'Destroy’

[Test] Check the bullets can't travel through obstacles/floors , 5
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Robovenger B3) Flying Enemies (Path)

Click on the 'Frame Editor' icon to go back to the FRAME EDITOR

[Reusable Skill - Cloning]
Right click on the 'Enemy 1' object > ‘Clone Object’ > leave the settings as Rows: 2 Colomns: 1 click 'OK’

Clickteam has now created a copy below called ‘Enemy 2’
[End]

[Import Artwork] Import ‘enemy 2.png’ for 'Enemy 2’ object

[Create opposite direction] Create opposite direction from the right facing animation black square
Exit the Image Edit window by clicking 'OK'

In the 'Properties Window' in the Values' category change the values

health: 15

explosion damage: 30

shoot chance: 160
shoot calc: 0 (leave)

16



Robovenger B3) Flying Enemies (Path)

[Select a Movement] Type: 'Path’

Still in the ‘Movement' category of the ‘Properties Window' for '‘Enemy 2'
click on 'Edit’ next to ‘Edit Movement'

Click the 'New line" icon on the ‘Path Movement Setup’

Click under the 'Enemy 2' object

Drag over the 2 square nodes and line, and change the speed in the 'Path Menu' to 8
From the 'Path Menu' turn on 'Loop the Movement' and 'Reverse at End’

On the 'Path Movement Setup’ click 'OK’

[Test] check the movement is suitable

17



Robovenger B4) Bullet Events

Click on the EVENT EDITOR icon to load the 'Event Editor’

In the 'Enemies’ event group, click 'New Condition’ >
‘Enemy Bullet' > 'Collisions’ > 'Another object’ > 'Player' object’ > 'OK’

Right-click for an action under the ‘Player 1" (Joystick logo) colomn >
‘Number of Lives' > 'Subtract from Number of Lives' > 1 > 'OK'

[Save]

We will add the object and rules for lives later
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Robovenger C1) Target and Arms

Firstly we'll make a target cursor for aiming
[Insert a Object] Insert an Active object

Right-click on the object and click 'Edit’
Using the Image Edit window draw a target
[Rename] Target'

Now we will add the player's arm with gun attached
[Insert a Object] Insert an Active object

Right-click on the object and click 'Edit’
Using the Image Edit window resize the image to w:32 h:16
Colour in the rectangle

[Reposition the hot spot] Place it to the left of the rectangle for it's joining point

Reposition the action point in the same way (Target icon)
place it on right of the rectangle for the location of where bullets spawn.

Drag the direction slider to it's second notch (8 directions)

Right-click on the black direction square >
'Created rotated directions’

Click 'OK' on the Image Edit window
[Rename] 'Arms’

19



Robovenger C1) Target and Arms

Right-click on the 'Player’' object and click 'Edit’

Reposition the ‘Action Point’ (target icon) to where the ‘Player’ objects shoulders would be
Click 'OK'

Now to add the event for the target

Click on the EVENT EDITOR icon to load the 'Event Editor’

Above the 'Enemies’ event group

Right-click on the number of the line (2) and click 'Insert’ > ‘A new event' >

'Special’ > 'Always’

Right-click under the Target’ column for an action, choose 'Position’ > 'Set X Coordinate..." > type in the
Expression Editor "XMouse™ (Without quotes) > 'OK’

Right-click on the same action under the Target’, choose ‘Position’ > ‘Set Y Coordinate..." > type in the
Expression Editor "YMouse” (Without quotes) > 'OK’

Right-click under the The mouse pointer and keyboard’ column on that event row for a new action
> 'Hide Windows mouse pointer’

Right-click under the 'Arms' column 'Position’ > 'Set Position’ > 'Relative to' > 'Player’ > 'OK’
> 'Options’ > check Originating from : 'Host Spot’ > 'OK’ > Set X: 0 Y: 0 > 'OK’

Right-click on the same action in the 'Arms’ column
'Direction’ > 'Look in directon of..." > 'Relative to' > Target' > 'OK' Zo



Robovenger C2) Bullets and Values

Click on the 'Frame Editor’ icon to go to the FRAME EDITOR
[Inserting an Object] Insert an 'Active’ object,

[Importing Artwork] ‘bullet 1.png’ (Not as animation)
[Rename] 'Rapid fire’

In the 'Properties Window' in the 'Values' category set these
Alterable Value A = Damage : 10

Alterable Value B = Start speed : 40

Alterable Value C = Reload time : 10

Alterable Value D = Life span : 100

[Add to a Qualifier group] ‘Bullets’

[Reusable Skill - Select a Movement] Physics - Static movement
In the ‘Movement Properties’ set these values

Friction: 0

Gravity: 0

Bullet: check

21



Robovenger C3) Weapon Select & Reload

[Inserting an Object] Insert an 'List’ object
[Rename] ‘Inventory’

Double click to edit the ‘Inventory’ List, on the 1st line type "Rapid fire" (no quotes)

And on the 2nd line type "-" (no quotes) click 'OK’
[Inserting an Object] Insert a '‘Counter’ object

[Rename] 'Reload’

In the 'Properties Window' 'Settings' category
Minimum value:0

Maximum value:0

Type: Horizontal bar

Click on the 'Event Editor’ icon to go to the EVENT EDITOR
[Add a Group of Events] "Weapons”

Click 'New Condition' > ‘Inventory' > 'Alterable Values' > 'Flags’ > 'Is flag off' > 'Flag 0' > 'OK’
Add an action under ‘Inventory’ object by right clicking ‘Set Current Line' > 1 > 'OK’

Click 'New Condition’ > ‘Inventory' > ‘Alterable Values' > ‘Flags' > 'Is flag on' > 'Flag 0' > 'OK’
Add an action under ‘Inventory’ object by right clicking 'Set Current Line' > 2 > 'OK’

Click ‘New Condition’ > The mouse pointer a keyboard' > 'User clicks' >
'Single click' 'Right click' > 'OK'’
Add an action under ‘Inventory’ object by right clicking 'Flags' > "Toggle' > 'Flag 0" > 'OK’

22



Robovenger C3) Weapon Select & Reload

Click ‘New Condition’ > 'The mouse pointer a keyboard' > 'Repeat while mouse-key is pressed' > 'Left button’ >
0K’

Right-click on the condition you just made and ‘Insert’ another condition
‘Reload’ counter > ‘Compare to a value' > 0 (already set) > 'OK'

Right-click under the ‘Create new objects’ column for that row and choose ‘Create object by name’ >
In the 'Expression Editor' click on the ‘Inventory' object

and select 'Get current line' > 'OK' > 'Relative to' >
'Arm’ > 'Options’ > check 'Action Point’ > 'OK' >
Set X:0 Y:0 is needed > 'OK'’

Right-click under the '‘Bullets’ column for that row to add an action ‘'Movement' >
'Physics’ > ‘Apply Impulse’ > In the ‘Expression Editor’ click on the ‘Group.Bullet’ object
'Values' > 'Values A to M’ > ‘Start speed’' > 'OK’ (This loads the angle)

> Type in dir("Arms”)*11.25 > 'OK’

Right-click under the 'Reload’' column for that row to add an action
'Set counter’ > In the 'Expression Editor’ click on the ‘Group.Bullet' object

Values' > 'Values A to M' > 'Reload time' > 'OK' 23



Robovenger C3) Weapon Select & Reload

Click 'New Condition' > 'The Timer' > 'Every’ > 0:Hour(s), 0:Minute(s), 0:Second(s), 1:1/100 > 'OK’
Right-click under the 'Reload’ counter column for that row and choose

'Subtract from counter’ > 1 > 'OK’

Right-click under the '‘Group.Bullets’ column for that row and choose

'Alterable Values' > 'Subtract from' > ‘Life span' > 1 > 'OK'

Click ‘New Condition' > 'Group.Bullets’ > ‘Compare to one of the Alterable values’ > Select 'Life span’ ‘Lower or
equal’ 0 > 'OK'

Right-click under the 'Group.Bullets' counter column for that row and choose 'Destory'
[Save]

[Test] Try holding down the left mouse button to fire

Click on the 'Frame Editor’ icon to go to the FRAME EDITOR

[Clone an Object] Clone the ‘Rapid fire' object col:1 rows:2
ITip! Zoom in to help right-clicking on the object

[Rename] "Flamethower”

[Importing Artwork] "bullet 3.png"

24



Robovenger C3) Weapon Select & Reload

In the 'Properties Window' in the Values' category, change to,
Alterable Value A = Damage : 2

Alterable Value B = Start speed : 5

Alterable Value C = Reload time : 0

Alterable Value D = Life span : 10

Double-click on the ‘Inventory’ list and change the 2nd line to "Flamethrower” (no quotes) > 'OK’
[Test] Test the two weapon options
Click on the EVENT EDITOR icon to load the 'Event Editor’

In the 'Weapons' event group click on 'New Condtion’ > 'Group.Bullets' > 'Collides’ > 'Backdrop’
In that row under the 'Group.Bullets' right-click for an action 'Destroy’

Click ‘New Condition’ > 'Group.Bullets’ > ‘Collides’ > 'Another object’ > 'Enemy bullet’ > 'OK’
In that row under the 'Group.Bullets’ right-click for an action 'Destroy’
In that row under the ' Enemy Bullet' right-click for an action 'Destroy’

Click ‘New Condition’ > 'Group.Bullets’ > ‘Collides’ > 'Another object’ > 'Group.Breakable’ > 'OK’
In that row under the ‘Group.Breakable’ right-click for an action > 'Alterable Value' > 'Subtract from' > Select
'Health" and click on the 'Group.Bullet’ > Values' > 'Values A to M' > 'Damage’ > 'OK'

Click ‘New Condition’ > 'Group.Bullets’ > ‘Collides’ > 'Another object’ > 'Group.QObstacles’ > 'OK’
In that row under the 'Group.Breakable’ right-click 'Movement' > 'Stop’
In that row under the ' Enemy Bullet' right-click for an action 'Destroy’

[Test] Try shooting barrels [Save] 2 5



Robovenger C4) Breakables Explode

Click on the FRAME EDITOR icon to load the 'Frame Editor’

[Inserting an Object] Insert an 'Active’ object,

[Importing Artwork] ‘explosion_1.png’ (As an animation)

While still int he Image Edit window right click on the Animation list ‘Stopped’ and 'Cut’
right click on the Animation list 'Disappearing’ and click ‘Paste’

[Rename] 'Explosion’

Place it outside the frame

[Add to a Qualifier group] ‘Bullets’ (So it will cause damage)

Click on the EVENT EDITOR icon to load the ‘Event Editor'

[Add a Group of Events] "Explosions”

In this event group click 'New Condition’ > ‘Group.Breakable’ > ‘Compare to one of the Alterable Values' >
'Health' 'Lower or equal’ 0 > 'OK’

Right-click for an action under the 'Group.Breakable' > 'Alterable Values' > 'Subtract from' >
'Health' 1 > 'OK’

26



Robovenger C4) Breakables Explode

In this event group click 'New Condition’ > ‘Group.Breakable’ > ‘Compare to one of the Alterable Values' >
‘Health' 'Lower or equal’ -60 (note minus sixty) > 'OK’

On that row Right-click for an action under ‘Create new object’ > 'Create object’ > 'Explosion’ > ‘OK' > ‘Relative
to’ > ‘Group.Breakable' > 'OK’

Right-click for an action under 'Explosion’ > ‘Scale / Angle' > 'Set Scale’ > In the Expression Editor type
OHeight( "Group.Breakable" ) * 0.02

> 'OK’

On the same action right-click under 'Explosion’ > 'Alterable Values' > 'Set’ > '‘Damage’ >

in the Expression Editor click on the 'Group.Breakable' > Values' >

'Values A to M'" > 'explosion damage' > 'OK’

On the same row right-click under 'Group.Breakable’ and click ‘Destroy’

In the 'Enemies’ event group add a 'New Condition’ > ‘Group.Enemies’ > 'Alterable Values' > '‘Compare to one of
the Alterable Values' > 'Health' 'Lower or equal’ -60 (note minus sixty) > 'OK'

Right-click under the 'Player 1" (Joystick) column > 'Score’ > 'Add to score' > 15 > 'OK'

27



Robovenger D1) Scrolling & H.U.D.

Click on the 'Frame Editor' icon to go to the FRAME EDITOR

In the 'Workspace Toolbar' select 'Frame 1'

In the 'Properties Window' in the 'Settings’ category set the size to be 10000x480
Click on the 'Event Editor’ icon to go to the EVENT EDITOR

Find an 'Always’ condition, and on that row right-click under the 'Storyboard Controls' > 'Scrollings' > '‘Center
window position in frame’ > 'Relative to’ > 'Player’ object > 'OK" > 'OK’

[Test] Move to the right and check the game scrolls

Click on the 'Frame Editor’ icon to go to the FRAME EDITOR
[Paint mode] Add in the level, enemies, barrels, floor etc.
Click on the 'Frame Editor’ icon to go to the FRAME EDITOR
[Inserting an Object] Insert an ‘Active’ object,

[Rename] "hud”

[Importing Artwork] "hud.png”

Drag it into position at the top of the screen

IBug! It covers the 'Reload’ counter 2 8



Robovenger D1) Scrolling & H.U.D.

Select the 'Reload’ from the side asset bar
From the Top Menu'’ click ‘Arrange’ > 'Order’ > 'Bring to front’
Drag to resize it over the word RELOAD on the 'hud’ object

Move the ‘Inventory’ onto the correct position on the ‘hud’ object

[Inserting an Object] Insert a 'Score’ object (Not Hi-score)
Move the the 'Score’ object onto the 'hud' object

[Inserting an Object] Insert a 'Lives’ object
Move the 'Lives' into the correct position on the 'hud’ object
Resize the lives box to be wider

Now we'll change the starting number of lives
Click on the Application name in the "Workspace Toolbar’
In the 'Properties Window' in the 'Runtime Options’ category scroll down and change

‘Initial # of lives': 5

[Test]
'Bug! The H.U.D. and list gets left behind

Click on the 'hud’ object in the 'Properties Window' in the 'Runtime Options' category
uncheck Follow Frame

Click on the 'Inventory’ object in the ‘Properties Window' in the 'Runtime Options’

category uncheck Follow Frame 2 9



Robovenger D2) Health Drops

[Inserting an Object] Insert an ‘Active’ object

[Importing Artwork] "health drop.png”

In the Image Edit Window select the ‘Disappearing’ Animation form the list

[Importing Artwork] “"health drop open.png”

In the Image Edit Window select 'Direction options’ and set the Speed to be 15

[Rename] "Health Drop”

Click on the EVENT EDITOR icon to load the 'Event Editor’

[Add a Group of Events] "Drops”

In the event group click ‘New Condition’ > 'Player’ object > 'Collides’ > 'Another object’ > 'Health Drop’
Right click on that row under the 'Player 1" (joystick) 'Lives’ > ‘Add to Number of Lives' > 1 > 'OK’
Right click on that row under the 'Health Drop’ (joystick) ‘Lives’ > 'Add to Number of Lives > 1 > 'OK’
[Test]

IBug! When collected it drops down, this is due to the Hotspot on the 'Disappearing’ animation, edit the
Hostpost position to macth the 'Stopped’ animations Hotspot

[Optional] Make the drop destrucatbale by adding the
Weapon Drop to the Group.Breakable qualifier and add

health and explosion damage alterable values. 3 o



Robovenger D3) Weapon Drops
Click on the FRAME EDITOR icon to load the 'Frame Editor’

[Inserting an Object] Insert an ‘Active’ object

[Importing Artwork] "weapon drop.png"

In the Image Edit Window select the ‘Disappearing’ Animation form the list
[Importing Artwork] “"weapon drop open.png”, repostion the hotspot

In the Image Edit Window select ‘Direction options’ and set the Speed to be 15
[Rename] "Weapon Drop”

[Inserting an Object] Insert a 'List’' object, and position it offscreen.

[Rename] "All Weapons”

Double click on it and add all the names of the bullets to it, a new line for each entry e.g.
Rapid fire

Flamethrower

Click on the EVENT EDITOR icon to load the ‘Event Editor'
In the event group ‘Drops’ click ‘New Condition’ > 'Player’ object > 'Collides’ > 'Another object’ > 'Weapon Drop’

Right click on that row under the 'All weapons' > 'Set current line' > RRandom(1, List Nb Lines("All Weapons")) >
0K’

Right click on that row under the ‘Inventory' > 'Change a line' > In the
Expression Editor click on 'Inventory’ ‘Get current line number’ > 'OK’ click on 'All Weapons'
'Get current line’ > 'OK’

Right click on that row 'Weapon Drop’ > 'Destory’
[Test] [Save] Clone more bullet types if you want 3 ’



Robovenger D4) Game Endings
[Add a Group of Events] "Ending game”

In that event group click ‘New Condition’ > ‘Player’ object > 'Position’ > "Test Position’ > Select the arrows in the
white square pointing left and the one pointing down > 'OK’

Right click on that row under the 'Player’ object > ‘Destory’
Right click on that row under the 'Arms’ object > 'Destory’

In that event group click ‘New Condition’ > 'Player 1' (joystick) > "When number of lives reaches 0

Right click on that row under the 'Player’ object > 'Destory’
Right click on that row under the 'Arms’ object > 'Destory’

Click 'New Condition' > The mouse point and keyboard' > 'The mouse’ object > ‘User clicks' > ‘Left button’
'Single click’ > 'OK'

Right-click on that condition and click ‘Insert’ 'Player’ object > 'Pick or count’ > 'Compare to the number of
"Player” objects’ > 0 > 'OK’

Right click on that row under the 'Storyboard Controls' > 'Restart Application’

In that event group click '‘New Condition’ > 'Player’ object > 'Position’ > Test Position' > Select the arrow in the
white square pointing right > 'OK’

Right click on that row under the 'Storyboard Controls' > 'Next frame'
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Robovenger Animations and E) Optional

If you haven't already you can import animations (Stopped, Walking, Crouch, Climbing, Jumping) for the
player and the arm directions. Remember to '‘Create oppposite directions’ and position the HotSpot at their
feet and Action Point at their shoulders.

E1) Levels Parallaxing - A Scrolling Background at different speed, see video
E2) Enemies Flanking - Getting enemies to run at you from off screen, see video
E3) Hanging to Platforms - Letting your character hang to platforms, see video

E4) Sounds, these sound can be used for these conditions

music Robocalypse 2.mp3 = background music, needs to be credited to Kevin McLeod Creative Commons 3.0
sfx enemy shoots.mp3 = When enemies fire

sfx explosion.mp3 = When an explosion is created

sfx game over.mp3 = When player falls off screen or lives reach 0

sfx go go go.mp3 = Start of frame

sfx health increase.mp3 = Health drop collection

sfx hover off.mp3 = When player is not hanging on a ladder

sfx hover on.mp3 = When player is hanging on a ladder

sfx new weapon.mp3 = Weapon drop collection

sfx player hurt.mp3 = When a enemy bullet hits a player

sfx player shoot.mp3 = When a bullet is created

sfx robot scream.mp3 = When enemy is destoryed

sfx stage complete.mp3 = When player leaves the right side of the screen

sfx thud.mp3 = When bullets hit backdrop or obstacles 3 3



